Subject: Re: tape problems....
To: None <>
From: David Brownlee <>
List: port-sun3
Date: 12/19/1996 20:28:02
On Wed, 18 Dec 1996 wrote:

>   WARNING: Extreme newbieness ahead
>   I've picked up a combo platter of a 386i w/expansion module (two scsi 
>   slot case w/tape drive) and a diskless 3/50.  The 386i has been brought 
>   back to life running SunOS 4.0.1 and I picked up a dirt cheap 80MB scsi 
>   drive for the 3/50.  I created the tapes on the 386i and then moved the 
>   expansion module onto the 3/50 so I could boot from it.  Booting went 
>   fine, loading the miniroot, sensing the IBM drive, etc.  Eventually I 
>   figured out the disk labeling and set up my partitions.
	Cool - You'll probably want to pick up a copy of the SunOS 4.0.2
	upgrade disks from :) (there's also a useful
	collection of programs compiled up for the sun386i there)

>   do i need to format these partitions after labeling them?  this used to 
>   be an IBM drive with DOS on it.  I wiped out those partitions before but 
>   I can still cat DOS data out of it..  if I need to format, can I do it in 
>   the miniroot?
	No, you can just 'newfs' them. If it is an old drive then you
	probably want to run the sunos format on it to check out any
	bad blocks first - the sun3 sunos boot media is available from the
	sun3 ftp site - check out the link from the NetBSD/sun3 web

>   basically, the miniroot seems to be reading OK at first.  When I try to 
>   dd the miniroot into the b partition, I get the following error:
>   st0(si0:4:0):no data found, requested size:64(decimal) data=00 00 00
>   0+0 records in
>   0+0 records out
>   I also got this error after trying weof after each file.  Using weof also 
>   gave me short read errors.  this was all using the stock instructions.
>   not knowing much about tape drives, I searched through the list archives 
>   and found out about the ibs obs problems and tried several combinations 
>   with no success.
>   Just curious if it was a tape read problem, I tried to dd the .welcome 
>   file into the b partition and it failed to write there.  Is the previous 
>   error message so cryptic as to actually be a hard drive error?
>   Just FYI, I can't work on the IBM drive on the 386i because it doesn't 
>   like it somehow.  It doesn't sense it at boot time even after it has been 
>   labeled.  The 386i has also stopped responding to the 3/50's tftp 
>   requests so I can't netboot it from there.  I'll probably install NetBSD 
>   on my Win95 box to boot it if that will help. that PC doesn't have SCSI 
>   so I can't modify the drive or access st0 there either.
	Nasty - I wish I could help on this :(
	I regularly netboot my sparc boxen from a NetBSD/i386 server,
	but the sun386i _should_ work ok... Maybe a marginal network

	Good luck.

		David/abs david@{,,}

System Manager: Southern Studios Ltd, PO Box 59, London N22 1AR.
Satisfied User: NetBSD, free Un*x {i386,sparc,mac68k,+more} ''.
  System Admin: MHM Internet, 14 Barley Mow Passage, Chiswick, London W4 4PH.
         SysOP: Monochrome, Largest UK Internet BBS - 'telnet'.