Subject: tape problems....
To: None <port-sun3@NetBSD.ORG>
From: None <>
List: port-sun3
Date: 12/18/1996 10:56:14
  WARNING: Extreme newbieness ahead
  I've picked up a combo platter of a 386i w/expansion module (two scsi 
  slot case w/tape drive) and a diskless 3/50.  The 386i has been brought 
  back to life running SunOS 4.0.1 and I picked up a dirt cheap 80MB scsi 
  drive for the 3/50.  I created the tapes on the 386i and then moved the 
  expansion module onto the 3/50 so I could boot from it.  Booting went 
  fine, loading the miniroot, sensing the IBM drive, etc.  Eventually I 
  figured out the disk labeling and set up my partitions.
  do i need to format these partitions after labeling them?  this used to 
  be an IBM drive with DOS on it.  I wiped out those partitions before but 
  I can still cat DOS data out of it.  if I need to format, can I do it in 
  the miniroot?
  basically, the miniroot seems to be reading OK at first.  When I try to 
  dd the miniroot into the b partition, I get the following error:
  st0(si0:4:0):no data found, requested size:64(decimal) data=00 00 00
  0+0 records in
  0+0 records out
  I also got this error after trying weof after each file.  Using weof also 
  gave me short read errors.  this was all using the stock instructions.
  not knowing much about tape drives, I searched through the list archives 
  and found out about the ibs obs problems and tried several combinations 
  with no success.
  Just curious if it was a tape read problem, I tried to dd the .welcome 
  file into the b partition and it failed to write there.  Is the previous 
  error message so cryptic as to actually be a hard drive error?
  Just FYI, I can't work on the IBM drive on the 386i because it doesn't 
  like it somehow.  It doesn't sense it at boot time even after it has been 
  labeled.  The 386i has also stopped responding to the 3/50's tftp 
  requests so I can't netboot it from there.  I'll probably install NetBSD 
  on my Win95 box to boot it if that will help. that PC doesn't have SCSI 
  so I can't modify the drive or access st0 there either.
  sorry this was so long, just trying to give all the background info...