Subject: Re: cg4 problems revisited...
To: None <>
From: Izumi Tsutsui <>
List: port-sun3
Date: 07/13/1996 12:43:13
In message <> on 07/11/96(21:51:16)
you Scott Ellis <> wrote:

 |>  |So..I was happy using bw2. ;-)  Sometime in the migration from 1.1
 |>  |to 1.2_Beta (actually happened when it was 1.1a), the autoconfig code
 |>  |broke.  On bootup, when the system got to cg4, initialized it, and was
 |>  |ready to continue... I'd get an MMU fault, and get dumped to the debugger. 
 |> I have a Sun 3/60 with cg4. When I built 1.2_Alpha kernel,
 |> I also got an MMU fault after initializing cg4.
 |> Then I built a kernel with "cc -O" (not "cc -O2"), it works fine.
 |Wow, that seems to have actually worked.  Guess it's a gcc bug?

I think that there are something wrong with m68k gcc optimizations.
There were some programs which didn't work with "gcc -O2" but 
they worked fine with "gcc -O".

 |The cg4 still doesn't work for me (I'm getting the odd vertical stripes,
 |and "big" pixels still), but it doesn't dump core on finding the cg4
 |I noticed that -O kernels have a tendency to hang when they are loading 
 |though...never seen it before with -O2 kernels, yet in tonights tests
 |with -O kernels, it's hung about 4 times as it initializes (543211+
 |12345/  hangs somewhere in that stage).

Umm.. I haven't seen such hangs at boot time. It seems a problem
with ufsboot or netboot.

 |Does the color display work on your 3/60?

Yes, the cg4 on my 3/60 works fine. It's a good Xtermnal which has
two screens cg4 and bw2. ;-)

Izumi Tsutsui	Nagoya University, Japan