Subject: Problems installing NetBSD from tape
To: Brett Glass <>
From: Tuomo Tikkanen <>
List: port-sun3
Date: 07/04/1996 16:37:50
In 3. July 1996 Brett Glass wrote:
> Yes, I have experienced EXACTLY the same problems as you. It appears that
> support for the Archive tape drive and Emulex controller, found in early
> Sun3's, is broken and hasn't been fixed, even though I mentioned the
> problem more than half a year ago on this list. I worked around the problem
> by using Sun's munix, instead of the miniroot, to get NetBSD onto the
> machine.

>From where I can found "munix"?
> I then began to experience core dumps and other odd failures, and gave up
> on using NetBSD on that machine. I still use it on others where it seems to
> be more stable.

Yep, yep, yep, no my Sun3/60 is a complete mess as I was able to "dd" the
miniroot to b partition of my drive and start the installation from there
(thanks to David Brownlee). I used ftp as installation media (as the tape
didn't work) and I was bit suprised because the lists tar program printed
to console were quite short when it untarred installation sets. I even made
this phase twice to ensure that it is ok ( and it wasn't like I later
noticed :-( ). There were some error of "broken pipe" when tar said "moving
to next file header" at end of each package. I didn't think this as an
error as I was doing just what the instructions on screen told me to do.

After load of installation sets from net the installation program did some
work for itself and my bells were ringed when there was message "Creating
devices.... MAKEDEV not found" and the installation continued. At that
point nothing could be done any more and when the installation program said
"Installation complete boot with reboot" or something like that I just
typed "reboot<RET>". First everything went find but the booting stoped when
there was phase where "init" program should be loaded but the file could
not be found.

Now the system is in kernel debuger and waiting command to continue. I think
I'll try to find SunOS4.1.1U1 tapes somewhere and install it instead of the
NetBSD. Do you think that one of the problems could be that the SunOS that
was previously installed to harddisk was version 4.0.1? If you do I
probably still try to intall NetBSD after I have installed SunOS4.1.1.

Still no NetBSD :-((

 << Tuomo-Markus Tikkanen <<>>  Work: >>
 << Nokia Research Center <<>> Univ.:      >>
 << P.O. Box 45           <<>> Voice: +358 0 4376 6480                  >>
 << FIN-00211 HELSINKI    <<>>   FAX: +358 0 4376 6850                  >>
 <<         HOMEPAGE         >>