Subject: Problems installing NetBSD from tape
To: None <port-sun3@NetBSD.ORG>
From: Tuomo Tikkanen <>
List: port-sun3
Date: 07/03/1996 20:01:46
Hello there,

I hope this is not a FAQ, but as I have would like to get my Sun3 to run
NetBSD ASAP I'll bothe all you.

My problem is that I don't succeed in installing the NetBSD on my
Sun3/60. I am using the method that was rated "easiest" in INSTALL.txt
i.e. I am installing from the tape. I have prepared the two installation
tapes as described in INSTALL.txt using SunOS4.0.1 on the same 3/60 where I
am going to install NetBSD. I have tested the tapes on SunOS and they
worked like supposed i.e. everything I put there I can also read.

When I boot from the boot tape the RAMDISK version of NetBSD-1.1 is loaded
OK and I can (if I will) use the edlabel program. But then comes the
problem -- I cannot load the miniroot from the tape. If I try to rewind the
tape as documented in INSTALL.txt (mt -f /dev/nrst0 rewind) nothing
happens... no life on tape unit :-(. Then I say mt -f /dev/nrst0 fsf 2 (as
it is next to do in INSTALL.txt) and tape unit makes two apathetic tries to
move the tape and the tape is forwarded probably by inch or two. After that
it is no surprise anymore that when I do the "dd bs=8k if=/dev/nrst0
of=/dev/rrsd0b" command the system cannot found any suitable data.

Is there any one who has had similar problems and/or can help me with
this problem? I'd like to have my NetBSD running as soon as
possible. Before you answer:
Yes, I have tested that the tapes work OK on the same tape drive when
     accessed from SunOS4.0.1
Yes, I have tried to write EOF after each file I have put on the boot
     tape. This was a bad thing to do because after that even the RAMDISK
     NetBSD didn't come up
Yes, I have tried to use separate tape that has only the miniroot and
     changed the tape in after the boot tape had done it's work. This had
     the same effect as trying to load miniroot from the same boot tape
Yes, I have used many different tapes
Yes, I have sat upside down on my chair when trying to install NetBSD
Yes, I have started to believe that the tape drivers in RAMDISK kernel are
No, I have not loosed my believe that one day I have a working NetBSD
    installed on my Sun3/60

Best Regards,

 << Tuomo-Markus Tikkanen <<>>  Work: >>
 << Nokia Research Center <<>> Univ.:      >>
 << P.O. Box 45           <<>> Voice: +358 0 4376 6480                  >>
 << FIN-00211 HELSINKI    <<>>   FAX: +358 0 4376 6850                  >>
 <<         HOMEPAGE         >>