Subject: MMU trap panic? Weird coincidences continue
To: None <port-sun3@NetBSD.ORG>
From: Jari Kokko <>
List: port-sun3
Date: 03/23/1996 13:46:05
I had three kernel panics today, MMU trap. I am running a Feb 22 based
kernel (I added MFS recently and have /tmp mfs_mounted).

I usually dial to a dial back service with kermit and start PPP on
that. Today, I was planning to try and get a sli(r)p connection to a
friend's FreeBSD machine, so I used kermit to login there.

I stty'd crtscts and then logged on to another machine to check for
mail. Emacs started, and sent XOFF-XON, resulting in an Isearch: ^Q.
At this point, a large fonted MMU trap text ran across the X screen.


After a reboot, tried again, this time doing stty crtscts on the
second machine as well. Same thing, MMU trap when trying to read mail,
after emacs xonxoffed me.


Third time ( I am pretty stubborn ), I did a stty -a and saw that the
ixon flag was there and so I did a stty -ixon crtscts and got emacs
running nicely without xonxoffing me. But kaplonk! another panic!

I fell back to my previous route, and ppp'd to work and this time
everything is going fine.

As far as I can tell, everything is pretty similar in both cases, I'm
using a V.34 to connect to a V.32bis (14.4k) in both cases; I have a
tty speed of 38400, RTS/CTS, no XON/XOFF.

How does using a serial line cause a MMU trap, I haven't the foggiest.

Jari Kokko

PS. I can't use my tape drive to write with tar or dump, I get SCSI
errors, I have three hatboxes chained, the first of which has the tape
drive. The configuration worked fine under SunOS 4.1.1 for a week,
until I dumped SunOS and started using NetBSD. I have si_options=3,
and reading tapes works just dandy.