Subject: Sun 3/60 Locking Up After Boot
To: None <port-sun3@NetBSD.ORG>
From: Curt Sampson <>
List: port-sun3
Date: 03/19/1996 12:48:58
A strange problem started with my Sun 3/60 last night. I had compiled
a new kernel (1.1, not current) a little while ago, and I realised
today the reason it was running so slow is that I'd forgotten to
set si_options. So I made a backup copy of the kernel, set si_options
to 7, and rebooted.

Now, regardless of whether I boot from the new kernel, the older
one with si_options set to 0, or the GENERIC kernel, my machine
gets part or most of the way through the boot process and something
wedges. Often it will get all the way to printing the date (and
presumably exiting /etc/rc), but then getty never seems to start.
It does boot in single-user mode, and when I tried this I found a
getty core dump. (There was no namelist, unfortuantely, but a
backtrace gave me just one address, so it seems no functions had
been called.)

I can drop into the kernel debugger with L1-A, but I don't have
much idea of what to do from there. I tried a few stack traces,
which led me for some time to believe that it was a serial port
problem, as my machine was always locking up in zsabort(). :-)

So, any suggestions? My machine is at home, where I don't have a
network, so if it's anything serious I may have to drag the thing
in to work.


Curt Sampson		Info at
Internet Portal Services, Inc.	
Vancouver, BC   (604) 257-9400		De gustibus, aut bene aut nihil.