Subject: Re: More 3/50 netbooting stuff
To: Julian Bean <>
From: Trent McNair <>
List: port-sun3
Date: 12/06/1995 13:49:51
On Wed, 6 Dec 1995, Julian Bean wrote:

> I had a 3/50 booting fine over ethernet some months ago, but I built it a
> SCSI boot disk, and have been using that ever since.  Then, I tried again
> recently, but with little success.
> The symptoms were classic - hanging in netboot, just after establishing its
> IP address.
> The booting is much more verbose now,
> >> NetBSD netboot [$Revision: 1.2a $]
> Boot device type: le: Sun/Lance Ethernet
> d_devbytes=4
> d_dmabytes=22754
> d_localbytes=0
> d_stdcount=1
> d_devtype=1
> d_maxiobytes=0
> prom_iopen: devaddr=0xffe0000 pte=0xf4000090
> prom_iopen: dmaaddr=0xfff43c10
> Using IP Address = CDC7FD19
> prom_iopen: succeeded, error=0
> le: missed packet
> boot: client addr:
> le: missed packet
> bootparamd: 'whoami' call failed
> boot: netbsd: Input/output error
> boot:
> And it waits for input...
> The only non-deterministic part is where the missed packets go, and how
> many there are.
> Uggg...
> If it wasn't for the fact it used to work.... 
> Any ideas, anyon 
> Jules
I had this _exact_ problem with netboot.  I am booting from a linux box 
as opposed to an SS so I think the problem must be with the netboot 
program.  I dont know why it does this (I also tried the newer version) 
but for now I'm using the boot program included with the linux kernel 
package. If you don't have anything against using a non-native bootblock 
I'll mail you a copy.

Trent McNair