Subject: Random coredumps
To: None <port-sun3@NetBSD.ORG>
From: der Mouse <mouse@Collatz.McRCIM.McGill.EDU>
List: port-sun3
Date: 12/04/1995 19:46:42
I've got a -3/150 I've been doing full world builds from source on.  It
started coredumping randomly.  First time I saw this the "make build"
had gotten to games/adventure and was formatting the manpage, then I
saw a chain of "signal 4" errors from make, one for each depth of
recursive make, and it exited.  (Signal 4 is SIGILL.)  I tried to
restart it and got an immediate "signal 4" error.  file also produced
such errors.  I rebooted and everything started working; the build
finished without further incident.  Examining the filesystem revealed
that it was sh that had coredumped initially and when I tried to

Looked to me as though the in-core copy of libc or something had
somehow gotten corrupted.  The only things that continued to work were
my shell (which is my own shell, and it was linked static) and bringing
down the system (which was done with another static executable).

It happened again, later, but I carelessly blew away the logfile and
cores from that incident, so I don't have more than the bare fact to

Anyone have any ideas where I might look next time this happens?

					der Mouse