Subject: Re: nfs_boot (exporting swap file from linux)
To: None <>
From: Chris Callanan <>
List: port-sun3
Date: 12/01/1995 14:29:40
User Gordon W. Ross, was known to have said:
> > > > panic: nfs_boot: mountd swap, error=72
> > > > Stopped at      _Debugger+0x6:  unlk    a6
> > > > db>
> > > 
> > > In error.h:  #define  EBADRPC     72      /* RPC struct is bad */
> > > 
> > > I would guess this means either a network error, or some
> > > file corruption somewhere...
> [...]
> > yup... i did a dump...  can't see anything obvious.  i've included
> > the dumpfile if you want to look at it.  its uuencoded, gzipped.
> > 
> > duvel is the 3/60, and chimay is my linux pc.
> I looked at the tcpdump, and I think the mountd on your linux box
> is refusing to provide an NFS handle for the swap file.  Normally
> mountd is only asked to make NFS handles for directories, but with
> NFS diskless boot, mountd is asked for a handle for a plain file.
> Strict compatibility with Sun-style NFS boot requires that mountd
> should honor mount requests for plain files.  There is probably
> some way to make linux export a swap file, but I'm not sure how.
> I think others on the port-sun3 list have worked around this
> linux problem, so you might ask there for some help.

this is a portion of what i have been working with...

you can see at the top that when i boot, it fails when trying to
nfs the swap file.  i was not having this problem before.  i have
tried with 3 different kernels of different vintages.  i had upgraded
to 1.1, but it boot a few times after i upgraded.  the other day
i booted and this occured.  i dont recall anything changing on my
linux machine.  

again... this used to work! ;)  

any ideas?



  Chris Callanan - CpE major 

   That's a Smith and Wesson, and you've had your 6. --James Bond