Subject: Keyboard problems.
To: None <port-sun3@NetBSD.ORG>
From: Paul Boven <>
List: port-sun3
Date: 08/09/1995 23:32:49
Hi all,

>>I get the "zs1b: fifo overrun" too.  zs1b is the mouse, and the message
>>appears as soon as I touch the mouse.  It does not appear at all thereafter.

Yes, that happens on my Sun, as well. Other problems: I occasionaly get
a bell (^G) that doesn't want to stop. At this point, X seems to die because
messages are suddenly displayed on the console, in stead of the Xconsole
window, messing up the X-display. Xdm then takes charge and restarts the
server etc. (keyboard still beeping), and after a while I can login again,
and then make the new xterm go beep, which finaly silences the keyboard.
But on other occasions, the same symptom (beeping) leads to a comlete
hang-up of the machine and I have to cylce the power.

It also happens that when having keyboard-problems I suddenly end up in
the kernel debugger, as if stop-a had been pressed. No panic or message is
given. Sometimes I can enter continue, but usualy the keyboard stays dead
and I have to turn off the machine.

>It sounds like the chip is not being fully cleared-out during open.
>We might have some hope of fixing this given a way to reproduce it.
>Can anyone describe how to make the overflow happen?

It usualy happens when the machine is still 'cold', one of my reasons for
suspecting hardware problems. However, mark the 'usualy': it can also happen
when I'm in the middle of a hextris game (when close to a new highscore, of
course) when the machine has been running for hours already. Another
keyboard-problem that seriously messes up hextris: the keyboard-repeat
sometimes doesn't shut up. So all my blocks dash to the left, or go down
whirling around. Worst, of course, is a repeating space... :(

For a while there seemed to be some correlation between the position of
the keyboard-cable and these errors, but I'm still not certain about that.
To test this, I just borrowed the keyboard from a friend's Sun3 that never
had these problems. Result: still fifo overflows. I can't test my keyboard
on his Sun, alas, because it died a few months after he got it :((

> > NetBSD is notoriously poor at serial I/O, but I think there's something
> > else here.  The mouse is no more than 9600 bps, which even NetBSD should
> > be able to handle.  Most likely something is not properly initialized
> > on zs1b at boot.

I don't recall any such problems on the ttya/ttyb ports, but then again they
have only been in use for a few days now, after getting the latest binary
snapshot. There are, however, always a few characters missing from the output
when I run ls, or in the fortune or login prompt. For a given baudrate,
these are always the same characters when I repeat the command. Most notably
is the b from the bash$-prompt when a command has finished. Because for
different baudrates and the same input the results do differ, I suspect
some kind of timing-problem. Could missing output to the keyboard cause it
to react in such ways? B.t.w., the terminal never missed characters when
connected to my Amiga or packet-radio-modem, even at it's highest (19k2)

This all is just meant to help you track down a potential bug: it doesn't
mean I'm not very happy with all the work you all did so far. Most days,
the Sun just works fine whitout any hitch. 
 E=  /// Paul Boven <> pe1nut@pi8daz.#twe.nld
    /// A2000HD, AmiTCP_4.0b and GG-II+ ethernet   QRV 145.575 MHz JO32KF
\\\/// "She  looked  like  she'd  had  sex,  with  a  tyrranosaurus  rex"
 \XX/                    Canibal Surf Babe, Afraid of Sunlight, Marillion