Subject: NetBSD/Sun3 status (it works partly)
To: None <>
From: Gordon W. Ross <>
List: port-sun3
Date: 12/16/1994 12:37:57
> From: "Harry Schreurs" <>
> Date:          Fri, 16 Dec 1994 17:56:06 GMT +0100
> Reply-To: (Harry Schreurs)

> Hi Gordon,
> I have problems compiling .../compat/sunos/sunos_misc.c using GCC 2.6.1.
[ sent a patch with a copy to Theo. ]

> Occasionally I got this message on the console:
>     pid 67: kernel format exception
> Do you know what's going on?

Haven't a clue.  I'd start by identifying the program that
is running as pid 67 and then find the message text...

> Apart from this, everything seems to be OK.
> No crashes of the kernel anymore when in single user mode.
> It seems that you finally solved the SEGV problem. Great!
> Also the BW display can be used a the console.

(So, have you got a bwtwo driver for me yet? 8-)

> When switching to multi-user mode I encountered the
> following problem:
>     It's impossible to login into the system!
>     I tried to set the password to something known value
>     using one of the two following methods:
>     passwd root
>     ed master.passwd
>     pwd_mkdb
>     However I never succeeded in doing a successful login.
>     I only was successfull in doing this using ftp.
> Is this because I miss certain crypt-related code?

Yes, probably.  In single user mode, I think you can:

	mount -u /
	mount /usr
	vi /etc/passwd
	[ make passwd fields all :: ]
	rm /etc/spw.db

Then you should not even be prompted for a password.
(though I'm not sure these instructions are enough...)

> Besides this I have the following minor problem:
>     Pressing 'L1-A' drops me into the debugger.
>     Stopped at  _Debugger+0x6:  unlk    a6
>     db>
>     At this point NetBSD doesn't respond to any keys pressed on
>     the keyboard!

Ugh.  I'm not sure this ever worked.  In sun3/dev/kd.c there is a
kdcngetc routine that tries to use the PROM to read the keyboard
(cheat) and the PROM quite likely requires the clock interupts at
level 7 (NMI) enabled to poll the keyboard.  The "right" way to
fix it is make kdcngetc poll just like zs.c:zscngetc() to get a
scan code, then translate it (as done by kbd.c) then return it.

>     When I start NetBSD with -d, this also gets me into the debugger.
>     In this case everything works fine!
Really!  You mean, later L1-A then works correctly?  Hmmmm...