Subject: kernel build ok (experiences)
To: None <>
From: Holger Veit <>
List: port-sun3
Date: 02/11/1994 09:21:46
I spent the last two nights building the Sun3-NetBSD kernel
(with success).

These are my experiences:

1. Configuration:
   Sun 3/260 with SunOS 4.1,
   gcc-2.4.5, gas-2.1.1 (see below)

2. The distribution is complete with two exceptions:
   a. 'mkdep', which you need for 'make depend' is missing.
      Get one from NetBSD-current, -0.9 whatever, this is
      just a shell script which mainly does 'gcc -M'.
      Replace the 'cc' in the script with 'gcc', the Sun cc is only K&R.
   b. It is wierd that the statically linked '' worked
      for me, but the gas in the distribution immediately dumped
      core at the first file. I rebuilt gas from scratch. I only
      found gas-2.1.1 on my CD ROMs, but this works, no complaints
      about ".type" or so as mentioned in the doc.

3. for TIMESINK: no problems. I was too confident that
   I directly modified TIMESINK to include an 'options DDB' as I 
   am accustomed to in all my test kernels. This later fails due to 
   an undefined element of a structure in db_aout.c. So this does not
   work yet.

4. make depend, with the 'mkdep' I got above, gives a number of
   gcc warnings of the type "0x.. not found", obviously this is
   the shell's interpretation of the direct data structures from
   TIMESINK.nfsdiskless. The make depend ends successful anyway,
   so ignore that.

5. Besides the fact that you do not only have sufficient time
   to get a cup of coffee, but even buy the coffee directly in Bolivia
   :-), the kernel compile worked without problems. There are some
   blurbs about comparisons of different pointers, but I forgot
   which, and they are usually not serious.

6. Also the tftp boot loader in netboot compiles.

7. The last step still waits: 
   How does this thing boot. I have yet to prepare a suitable NFS
   environment on my PC, so this will need some time.
   Adam recommended in private mail just to boot the kernel and
   wait for the expected hang at mountroot(). I try this after
   finishing the disk backup, although, since there are no disk
   drivers in the kernel, it is unlikely that I find the right I/O
   addresses to initiate a corrupting disk operation.

So far, success. What I need next is:
  - an ie driver (yes I was hit hard with the 3/260 :-))
  - a xy driver (Xylogics 450/451)
    or a sd driver.
Chances are for the ie at first.

         Dr. Holger Veit                   | INTERNET:
|  |   / GMD-SET German National Research  | Phone: (+49) 2241 14 2448
|__|  /  Center for Computer Science       | Fax:   (+49) 2241 14 2342
|  | /   Schloss Birlinghoven              | Had a nightmare yesterday:
|  |/    53754 St. Augustin, Germany       | My system started up with
                                           | ... Booting vmunix.el ...