Subject: re: Problems trying to debug pkgsrc/mail/milter-greylist
To: Jochen Kunz <>
From: matthew green <>
List: port-sparc64
Date: 11/22/2007 20:17:54
   >    2) Are gdb or libpthreads on sparc64 known to have any problems?
   4.0 still uses SA threads and AFAIK SA threads never worked well on
   sparc64. The situation improved a lot when -current switched to a new
   threading model a while back. E.g. firefox was unusable on sparc64 with
   SA threads but runs quit nice on -current with the new non-SA threads.
   So, if you want / need to use a threaded application you have to switch
   either to -current on sparc64 or to an other machine architecture if you
   want / need to stay at 4.0. :-(

one other option is to try with the gnu pth library or some
other fully-userspace pthread library.