Subject: Re: multiprocessor sparc64
To: Martin Husemann <>
From: Chris Ross <>
List: port-sparc64
Date: 06/11/2007 22:14:35
On Jun 11, 2007, at 12:16 PM, Chris Ross wrote:
>> Well, if you are able to use ddb, you can try ;-)

   Well, my first few attempts to do anything useful with ddb seem  
fairly useless.  I tried getting backtrace information, which tends  
to just give me nothing.  I tried starting with -d, so I could set up  
a breakpoint, and while I think that worked (I got a "Trap 1"), I  
could hardly do anything with ddb.  It seemed kinda out to lunch.   
Maybe it was trying to run when a processor was only half up, as  
that's where I put the breakpoint.

   Anyway.  If you had any suggestions, or just general pointers on  
NetBSD/sparc/sparc64 kernel debugging, I'd be happy to hear them.   

> root on AA.BB.CC.DD:/export/sparc64/nfsroot
> root file system type: nfs
> /etc/rc.conf is not configured.  Multiuser boot aborted.
> Enter pathname of shell or RETURN for /bin/sh:
> Then, I hit return, and get:
> trap typT 0x10: cpu 1, pc=1008e5c npc=1008e60 pstate=44820006<PRIV,IE>
> kernel trap 10: illegal instruction
> cpu0: kdb breakpoint at 1008ee4
> cpu0 paused.
> Stopped in pid 0.3 (system) at  0x1008e5c:      done
> db{1}>

   Interesting, if I boot again, I can [repeatedly] get it to produce  
the following if I don't hit return.  It will prompt for me to enter  
a shell, then in only a couple/few seconds panic:

Enter pathname of shell or RETURN for /bin/sh: panic: lockmgr: no  
cpu1: kdb breakpoint at 140dc80
cpu0: kdb breakpoint at 1008ee4
cpu0 paused
Stopped at       netbsd:cpu_Debugger+0x4:           nop

   Also likely doesn't tell you much of anything, but it does  
indicate that I apparently can't make it run single user for me,  

   Let me know if there's anything else you'd like to see, and as  
mentioned above, any general pointers to places to learn things to  
make myself more useful on this front, point away.  :-)

   Thanks much for your time...

                                  - Chris