Subject: Re: 1.6.2_RC4 kernel panic
To: Andrey Petrov <>
From: ali (Anders Lindgren) <>
List: port-sparc64
Date: 03/03/2004 09:22:42
On Tue, 2 Mar 2004, Andrey Petrov wrote:

> On Wed, Feb 25, 2004 at 02:23:06PM +0100, ali (Anders Lindgren) wrote:
> > Tried to build ncurses from pkgsrc on 1.6.2_RC4/sparc64,
> > with pkgsrc gcc 3.3.2. It crashes pretty bad, and "sync"
> > from "db" crashes again so something really fucked the kernel up.
> >
> > This is on:
> > 	NetBSD 1.6.2 (IDA) #0: Thu Feb 12 22:15:42 CET 2004
> > and:
> > 	cpu0 at mainbus0: SUNW,UltraSPARC @ 143 MHz, version 0 FPU
> >
> > I hope this can be of some help to someone. Kernel config attached.
> >
> How reproducable is that? I'd try -current.

Probably not. I rebuilt ncurses, and it just worked.

> There are several important improvements in it, integrated gcc33,
> threads, and lot of kernel fixes. Unless your problem is ultra1-related
> I wouldn't expect -current to be worth.

*cough* I just _downgraded_ to 1.6.2_RC4 because the -current I was
running (1.6ZH and later 1.6ZI, Jan -> early Feb) was kernel panicking
at such a rate as to render the machine unusable, and this machine needs
to be up and running -- it's running my named, mail and http servers.
I really really want to run -current instead if I can.

  It would kernel panic in VFS, and other places, during pkgsrc builds
etc., and when I ^C'd a foreground named9 during testing it crashed so
hard I had to drive to the server room and power cycle the machine (you
know you've crashed a sun hard when the serial console doesn't work! :-) )
which is a major nuisance since said server room is 35km from my home.
Unfortunately I didn't get a chance to save those ddb trace outputs. :-/

  So far 1.6.2 has been otherwise stable, but I will surely switch back to
-current for the integrated gcc3 and working pthreads as soon as someone
can confirm it's stable enough again (my previous Nov 15 -current seemed
rather stable!) to run my named, mail and http server on.