Subject: PowerLite 85 floppy firmware patch
To: None <>
From: Cliff Wright <>
List: port-sparc
Date: 05/14/2001 16:45:05
  I have 2 RDI PowerLite 85 laptops. I was not able to boot from a
NetBSD 1.5 CD from "The NetBSD Mission". So made a floppy. However
their was an error on both laptops, not allowing me to boot from the
floppy, and the Open Boot Prom(OBP) command
"test floppy" would not work, returning the error
"Track 0 reported when on track 2."
I have a firmware patch below which will fix this problem, in case someone
else wants to use these old laptops. This allowed either NetBSD, or Linux to
boot from the floppy drive.
  Also I found a company that made
much larger capacity SCSI hard drives that would replace the original IBM
hard drives. The company was: Mac Components Engineered PowerBook Products.
These PowerBook drives fit, and worked just fine(Sept 99).
  I tracked the error down to the point
where it appears their is a delay from the head moving off of track 0,
to when the true status is reported, in the drive itself.
Then I found their was an error
when detecting going back to track 0. The initialization routine which
is used both for the "test floppy" command, and the OBP open, used by
the NetBSD boot routines, checks for both of these conditions, by seeking
to track 2, then returning to track 0. I found that when returning the 
head to track 0 from track 2 one could wait forever for the track 0 status,
and not receive it. But if returning from track 4, it worked.
So the patch involves changing the seek to that of track 4, and delaying
before checking the track 0 status.
  To apply the patch use the OBP commands nvedit, nvstore, to edit, and
save the non-volatile ram(ctrl-c to leave the editor).
Use the OBP command "setenv use-nvramrc? true".
to allow the non-volatile ram to be read on power-up.
The patch follows:

: trk0_delay
    50 ms 4
['] trk0_delay false ['] 4 false ffd34e90 (patch)
4 true ['] 2 false ffd34f28 (patch)