Subject: Re: dd: /dev/rsd0b: Read-only file system
To: None <>
From: T. M. Pederson <>
List: port-sparc
Date: 12/09/1999 23:25:15
On Fri, 10 Dec 1999 00:30:30 +0200, Antti Kantee wrote:
>On Thu Dec 09 1999 at 21:22:08 +0100, Manuel Bouyer wrote:
>> Maybe it's because the partition is marked as 'unused' in the disklabel ?
>> sd.c will refuse to open a device marked unused, unless it's the raw device.
>Nopes, it's marked as swap, read the disklabel provided. Need I tell you
>that I was trying to write to a raw device?
>Also, I played around with this a little also today. The most
>interesting result I could achieve was getting 3 records written and
>after that the fourth one failed (with read-only filesystem). it's magic

Today I upgraded an IPC from 1.4.1 to the 1.4L snapshot.  I got
essentially the same results wrt to writing to an available
partition; dd (and stdout in other tries) failed due to read-only

This was with a new (blank) 1 GB drive freshly attached and with
a fresh disklabel.  As the 1 GB was (and still is, I'm still in
the middle of the upgrade) not assigned to any particular place,
I've been free to mess with the configuration of it --- nothing
I've had time for makes a difference.

I finally gave up, cycled the box to single-user and tried to
dd the image to swap, which worked.  However, even when
single-user, the new drive still claimed to be read-only.

Mounting the filesystem of the new drive yielded an ordinary
rw mount.

I'll be testing the dd from 1.4L on it either Friday or Monday.
T. M. Pederson <>
PGP key can be found at
"I'm not talking about people here; I'm talking about me." --anon.