Subject: Re: NFS mounting anomalies from SunOS machines?
To: None <port-sparc@NetBSD.ORG>
From: Greg Earle <earle@isolar.Tujunga.CA.US>
List: port-sparc
Date: 10/23/1995 18:32:41
> Normally I run standalone with no NFS mounts, so I've never run across this
> before.  A fellow NetBSD/SPARC 1.0 user at JPL asked me about a problem he
> has with NFS mounting a SunOS 4.1.3 Sun onto his NetBSD 1.0 SPARCstation.
> So I tried it myself, and sure enough ran into something similar:

Thanks to Chuck Cranor for pointing out that "-o -P[,...]" is needed to make
the underlying mount_nfs use a priviledged port for the mount.

I was able to successfully mount and unmount the SunOS machine using "-P".

There is still a leftover turdlet, however; I still can't access "/mnt"
until/unless I actually mount something onto it:

netbsd4me:1:68 % sudo ls -ldg /mnt
ls: /mnt: Permission denied
netbsd4me:1:69 % sudo ls -ldg /mnt > /dev/null
ls: /mnt: Permission denied
netbsd4me:1:70 % sudo ls -ldg /mnt
ls: /mnt: Permission denied
netbsd4me:1:71 % sudo ls -lg / > /dev/null
ls: mnt: Permission denied
netbsd4me:1:72 % sudo mount -v -t nfs -o -i,-P mipl7:/var/spool/mail /mnt
mipl7:/var/spool/mail on /mnt type nfs
netbsd4me:1:73 % sudo ls -ldg /mnt
drwxrwsrwt  3 root  6  2560 Oct 23 18:25 /mnt
netbsd4me:1:74 % sudo ls -lg / > /dev/null
netbsd4me:1:75 % sudo umount -v /mnt
/var/spool/mail: unmount from /mnt
netbsd4me:1:76 % sudo ls -ldg /mnt
ls: /mnt: Permission denied

Thanks again to Chuck for the quick answer.  Now for the "fastboot"  :-)

	- Greg