Subject: Re: my O2 udpate.
To: Ken Wills <>
From: Matt Thomas <>
List: port-sgimips
Date: 11/24/2000 21:12:18
At 08:38 PM 11/24/2000 -0600, Ken Wills wrote:
>* Matt Thomas <> [001124 15:48]:
> > At 03:20 PM 11/24/2000 -0600, Ken Wills wrote:
> > >* Matt Thomas <> [001124 00:50]:
>[ ... snipped various crashing stuff ... ]
> > >On another note, does anyone have swap working at the moment? I've tried
> > >getting mine
> > >to see some, but without sucess - netbsd disklabel won't allow me to 
> label
> > >the disk,
> > >and SGI's fx doesn't let me do type 'swap' nearest thing is type 'raw'.
> > >Anyone had any
> > >success with this (I want it for crash dumps).
> >
> > I'm running diskless.  I've stopped using swap partitions and use swap
> > files now.
>How did you configure the swap files? I can't get it to sucessfully
>accept any files I point it to. I've tried ordinary files, dd into files, 
>vnd . I'm obviously missing something here. How do you configure and add 
>swap files?

dd if=/dev/null bs=1m count=96 of=/var/swap ; chmod 600 /var/swap
swapctl -a /var/swap

> > >You look like you might have a problem in your kernel config file though:
> > >
> > > > vendor 0x9004 product 0x8078 (SCSI mass storage) at pci0 dev 1 
> function 0
> > > > not configured
> > >
> > >Are you sure ahc is correct in you config file?
> >
> > I disabled ahc so I could boot.  So, no, there isn't a problem.
>Ahh. Right. Here's mine, for the record: (This is from about 1 week ago)
>NetBSD 1.5K (EL1) #2: Wed Dec 31 16:36:59 PST 1969
>65536 KB memory, 52260 KB free, 6848 KB for ARCS, 3376 KB in 844 buffers
>mainbus0 (root): SGI-IP32 [SGI, f]
>cpu0 at mainbus0: MIPS R5000 CPU (0x2321) Rev. 2.1 with MIPS R5010 FPC 
>Rev. 1.0
>cpu0: L1 cache: 32KB/32B instruction, 32KB/32B data, two way set associative
>cpu0: No L2 cache

No L2 Cache?  Mine has 1MB.  Too bad NetBSD doesn't use. :(

>crime0 at mainbus0 addr 0x14000000: rev 1.1
>mace0 at mainbus0 addr 0x1f000000
>mace0: isa sts 0
>mace0: isa msk 0
>com0 at mace0 offset 0x390000 intr 4: ns16550a, working fifo
>com0: console
>com1 at mace0 offset 0x398000 intr 4: ns16550a, working fifo
>pckbc0 at mace0 offset 0x320000 intr 5: stub
>lpt0 at mace0 offset 0x380000 intr 4: stub
>mec0 at mace0 offset 0x280000 intr 3: MAC-110 Ethernet, rev 1
>mec0: station address 08:00:69:05:de:ef
>mec0: sorry, this is not a real driver
>nsphy0 at mec0 phy 8: DP83840 10/100 media interface, rev. 1
>nsphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
>macepci0 at mace0 offset 0x80000 intr 7: rev 1
>macepci0: ctrl ff0005ff
>pci0 at macepci0 bus 0
>pci0: i/o space, memory space enabled, rd/line, rd/mult, wr/inv ok
>ahc0 at pci0 dev 1 function 0
>ahc0: interrupting at mace
>ahc0: Using left over BIOS settings
>ahc0: aic7880 Wide Channel A, SCSI Id=0, 16/255 SCBs
>scsibus0 at ahc0 channel 0: 16 targets, 8 luns per target
>ahc1 at pci0 dev 2 function 0
>ahc1: interrupting at mace
>ahc1: Using left over BIOS settings
>ahc1: aic7880 Wide Channel A, SCSI Id=0, 16/255 SCBs
>scsibus at ahc1 channel 0 not configured
>tlp0 at pci0 dev 3 function 0: DECchip 21041 Ethernet, pass 2.1
>tlp0: interrupting at mace
>tlp0: Ethernet address 00:e0:29:10:4c:38
>tlp0: 10baseT, 10baseT-FDX

At least I have 100-FDX. :)

>biomask 7f netmask 7f ttymask 7f clockmask ff
>ahc0: target 1 using tagged queuing
>sd0 at scsibus0 target 1 lun 0: <SGI, SEAGATE ST31230N, 0272> SCSI2 
>0/direct fixed
>sd0: 1010 MB, 3992 cyl, 5 head, 103 sec, 512 bytes/sect x 2070235 sectors
>boot device: <unknown>
>root device: sd0a
>dump device (default sd0b):
>file system (default generic):
>root on sd0a dumps on sd0b
>mountroot: trying nfs...
>mountroot: trying ffs...
>root file system type: ffs
>init: copying out path `/sbin/init' 11
>/dev/sd0a: file system not clean (fs_flags=0); please fsck(8)

I'm running diskless since I don't (yet) want to blow away IRIX
and I don't have a SCA disk (though one should arrive next week).
Also I don't have want to worry blowing away my disk partitions. :)

>Typically the above machine will panic with:
>panic: lockmgr: no context
>Stopped at      0x800fe860:     jr      ra
>                 bdslot: nop

See that panic quite a bit

>or more infrequently:
>panic: TLB out of universe: ksp 0xc490bf78 epc 0x8004b3d4 vaddr 0xcfb1f000
>Stopped at      0x800fe860:     jr      ra
>                 bdslot: nop

And that too.

Matt Thomas               Internet:
3am Software Foundry      WWW URL:
Cupertino, CA             Disclaimer: I avow all knowledge of this message