Port-prep archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Trouble booting an IBM 7248 after installation

Hello all,

I’ve *almost* successfully installed NetBSD on my IBM 7248. My system is a 
little special though - the SCSI drive that it had was bad, so I instead 
installed on a CF Card that’s plugged into the IDE controller. The installation 
of NetBSD went beautifully, however I can’t boot my system.

The SMS sees the CF card as a bootable device, and when booting to it, the 
serial console hangs and the system never comes up. There’s no real activity 
happening on the CF card.

I then tried creating a netbootable image with the hope of netbooting into my 
installed system. I booted up the installer again, and dropped to a shell. I 
chrooted into my system and did /usr/mdec/mkbootimage -m prep -b 
/usr/mdec/boot_com0 -k /netbsd boot.fs and tried netbooting again. The system 
grabbed it via tftp, but it hung afterwards. Again, there were no reads on the 
CF card.

It’s worth noting that the CF card is 8GB, and SMS only sees it as roughly 3.7 

Here’s the partition table:

# fdisk /dev/wd0 
Disk: /dev/wd0c
NetBSD disklabel disk geometry:
cylinders: 15538, heads: 16, sectors/track: 63 (1008 sectors/cylinder)
total sectors: 15662304

BIOS disk geometry:
cylinders: 975, heads: 255, sectors/track: 63 (16065 sectors/cylinder)
total sectors: 15662304

Partitions aligned to 16065 sector boundaries, offset 63

Partition table:
0: Linux/MINIX (sharing disk with DRDOS) or Personal RISC boot (sysid 65)
    start 63, size 9800 (5 MB, Cyls 0-0/156/35), Active
        PBR is not bootable: All bytes are identical (0x00)
1: NetBSD (sysid 169)
    start 9863, size 15652441 (7643 MB, Cyls 0/156/36-974/237/63)
        PBR is not bootable: All bytes are identical (0x00)
First active partition: 0

And the disklabel:

# /dev/wd0c:
type: unknown
disk: TS8GCF133      
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 16
sectors/cylinder: 1008
cylinders: 15538
total sectors: 15662304
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0           # microseconds
track-to-track seek: 0  # microseconds
drivedata: 0 

8 partitions:
#        size    offset     fstype [fsize bsize cpg/sgs]
 a:  15127056      9863     4.2BSD   2048 16384     0  # (Cyl.      9*-  15016*)
 b:    263088  15136919       swap                     # (Cyl.  15016*-  15277*)
 c:  15662304         0     unused      0     0        # (Cyl.      0 -  15537)
 e:      9800        63       boot                     # (Cyl.      0*-      9*)

Any help would be very much appreciated.

William Orr

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

Home | Main Index | Thread Index | Old Index