Subject: Re: Unsupported RS6k's and ofppc
To: Jochen Kunz <>
From: Tim Rightnour <>
List: port-prep
Date: 03/11/2006 23:15:51
On 11-Mar-2006 Jochen Kunz wrote:
> Yes. The first thing I tried with the PowerStack II was port-prep as it
> is a PReP machine. I had to notice that the OFW on my machine provides
> no residual data so port-prep was out of question. Then I started to
> hack on port-ofppc. PPC-BUG would be fine, but where to get and how to
> install?

Yeah.. basically it's prep compliant when provided with PPCBUG firmware,
without it it is mostly-OFW compliant.

How to get.. not sure.. but I'm told you can basically flash it on from a
floppy image.

>> Second.  The 7043-150 may or may not be a transitional machine like
>> the 7025. If it is, I believe it also provides residual, and can boot
>> and run prep.
> The 7043-150 is CHRP only. No residual data and CHRP memory map.

You're positive no residual?  I've seen a few CHRP IBM machines that still
provided residual if you asked for it.

> The problem with the PowerStack II is not interrupt related. It seems I
> can't access PCI memory space. PCI IO works fine. That is the reason why
> ex(4) worked: ex(4) preferes PCI IO and does not provid CSRs in PCI MEM
> region. tlp(4) and esiop(4) want PCI MEM.
>> I'd be more than happy to help you with OpenPIC/MPIC issues.
> You should not have said this. ;-)
> OK, I'll bring my patches for port-ofppc up to -current and leave the
> interrupt stuff to your amusement. There are other open issues like MD
> disklabel stuff that I have to fix.

Yeah.. contact me off list about this.  I'd be interested in seeing some PCI
dumps for the machine.  One hint, my problem was that after I mapped the
openpic, the PCI_NETBSD_CONFIGURE option went behind my back and remapped it,
making it impossible to talk to anymore.  So while it wired up fine, once that
ran it was toast.

Tim Rightnour <>
NetBSD: Free multi-architecture OS
Genecys: Open Source 3D MMORPG: