Subject: Re: Installing netbsd/prep on ibm rs/6000 7043-43p
To: None <>
From: Arpi <>
List: port-prep
Date: 06/06/2003 15:47:22

> On Fri, Jun 06, 2003 at 12:57:38PM +0200, Arpi wrote:
> > I'm having trouble installing netbsd on $SUBJ system.
> 	I had it too :)
> > I've also tried to write generic.fs, generic_com0.fs and sysinst_com0.fs on
> > floppy and boot, with no success.
> 	When I tried, it hang on parallel port.
> > prepcd.iso cdrom. (readme says that there should be a file named INSTALL but
> > isn't)
> 	AFAIK there's no INSTALL/HOWTO: what I did is
> 	- dd the floppy image I got from Mr. Nonaka[1]
> 	- boot from that

thanks, your image file worked for me :)
(it's a -140 system anyway, 200mhz 604e cpu)

> 	- setup a nfs server
> 	- download and extract the tarfiles


> 	- mount the extracted root on rs6k via nfs

huh, how?

booting the image reults:

root device:
use one of: pcn0 sd0[a-h] sd1[a-h] cd0[a-h] sd2[a-h] sd3[a-h] ddb halt reboot

// i've tried cd0 (prepcd.iso cdrom is in the drive) but failed
// then i've tried pcn0:

root device: pcn0
dump device:
// what is 'dump' device? swap?

file system (default generic):
root on pcn0
nfs_boot: trying DHCP/BOOTP
nfs_boot: DHCP next-server:
nfs_boot: my_addr=
nfs_boot: my_mask=
nfs_boot: gateway=
// fine, it got IP from my dhcp server

nfs_boot: getfh - no pathname
no file system for pcn0
cannot mount root, error = 79
// so, how/where can i tell it the IP address of NFS server and the path on it?

> 	- partition/newfs the disk(s)
> 	- extract the files again on disk(s)
> 	- boot from floppy and mount root from disk
> 	I still didn't complete the procedure (machine still boots from
> 	floppy/serial console) as it got rebooted only once, and I'm
> 	lazy.
> 	I think you'll find in the archives the wiser way to
> 	partition/format the disks.

I hope so :)
I'm new to bsd, i'm using and administrating linux and AIX since ages, but
never seen/use/install *bsd yet. Actually i've started thuis
let's-install-bsd-then thing for fun, and because this rs6k box is low for
aix 4.3 (64mb ram was always filled by aix's shit) so i wanted to try sth
else (linux/bsd, but linux is boring so i decided to try bsd)

A'rpi / Astral & ESP-team

Developer of MPlayer G2, the Movie Framework for all -