Subject: Re: Installing on an RS/6000 43P-140
To: None <>
From: Patrick Finnegan <>
List: port-prep
Date: 09/08/2002 10:42:43
On Sun, 8 Sep 2002 wrote:

> On  7 Sep, Patrick Finnegan wrote:
> > I've downloaded the '7043boot.fs' file, and am able to successfully boot
> > to a point where it asks me for a root device.
> >
> > Now, can anyone tell me how to get an installer running?
> You need to boot the machine with the "install" image. This should be
> in the same directory where you found the "7043boot.fs". (BTW: where
> did you find this file? I never noticed it bevore.) At least on
> should be the image you need.

I found the file on the main netbsd ftp server in:
It's the only file in that directory.

I've just tried the newest sysinst image:
It has the same problem of panicing that the May 'official' snapshot does:

panic: intr_establish: can't share level-triggered with edge-triggered irq 7

In fact, it seems that the file '7043boot.fs' is the only thing I can make
boot on here besides my set of IBM diagnostics, which isn't useful as an

> Note that sysinstall doesn't make the disk bootable. You will need to
> do some black magic with fdisk to create a bootable disk. The PREP
> machins have a MBR partition table (like i386) with a partition of type
> 65 that contains the bootimage. There is an other partition of type 169
> (?) that contains the BSD part of the disk, i.e. there is a BSD

I think you mean 41 -- 'PPC Prep Boot'.  Yeah, I know about that, I have
another PREP machine, a IBM PowerStation 850, running Debian Linux at the

> disklabel and all BSD slices in it. I was never successful in creating
> a bootable MBR partition table. Finaly I dd-ed the boot.fs image to the
> disk. This image has a valid, bootable MBR partition table. Then I
> edited this MBR partition table by hand and added the BSD partition. The
> rest was the usual "install by hand": disklabel, newfs, mount, tar, ...
> The machine can boot from its own disk now, but I have to enter the
> root device each time. And I don't know how to install an other kernel.

All I've had to do on linux is dd a new zImage.prep into the 'boot
partition'.  I'm sure there's something similar for netBSD.

> Additional note: As usual I was not able to find a working floppy to
> boot the machine from. So I simlpy tried to boot the floppy image via
> network (bootp/tftp). Surprisingly this worked very well. (On a
> 43P-100, your machie is a different type.)

Yes, a 7043 vs a 7248.  What file exactly is the kernel that I need to
be able to net-boot it?  Should I be able to just use a plain kernel -
like netbsd.INSTALL.gz, or do I need one of the sysinst.fs files?

-- Pat