Port-powerpc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: MPC5200 support

Frank Wille wrote:
>Robert Swindells wrote:
>>> Why was it necessary to include ofcons?
>> Because without it I lose any debug output. I have some ideas why but
>> haven't fixed it yet.
>> When the psc uart driver works then the ofcons code can be deleted. The
>> plan was to get to the point where I could telnet into it then fix the
>> uart code.

>Ok, makes sense. Do you have the impression that the interrupts are
>working correctly?

They work for the PCI slot, I think they should work for other devices.

>I ask because I tried the kernel on my Efika today. It reaches the
>boot- prompt and even reports the name and dimensions of my hard
>disk. But there are also messages about "lost interrupts".

The disk controller needs to be in PIO mode until we get Bestcomm to

Try this:

--- mpc5200_ide.c~      2009-06-02 14:35:09.000000000 +0100
+++ mpc5200_ide.c       2009-06-03 20:27:22.000000000 +0100
@@ -109,7 +109,8 @@
        /* Fill in wdc and channel infos */
-       sc->sc_wdcdev.sc_atac.atac_cap = ATAC_CAP_DATA16 | ATAC_CAP_PIOBM;
+       sc->sc_wdcdev.sc_atac.atac_cap = ATAC_CAP_DATA16 | ATAC_CAP_PIOBM |
+               ATAC_CAP_NOIRQ;
        sc->sc_wdcdev.sc_atac.atac_pio_cap = 0;
        sc->sc_wdcdev.sc_atac.atac_channels = sc->sc_chanarray;
        sc->sc_wdcdev.sc_atac.atac_nchannels = 1;

>Unfortunately I had to boot the kernel directly, because I couldn't
>find out why ofwboot failed. If reports "root addr=" and waits

I just boot the kernel too, I boot the latest device tree supplement
first though.

I have put it in ftp.netbsd.org:/pub/NetBSD/misc/rjs/efika.forth

>Strange, I'm sure I had it working last year. I have set
>"boot-protocol" in OFW to "dhcp". Other settings don't even allow me
>to load ofwboot over the net... :|

I do:

boot eth efika.forth
boot eth netbsd.ofppc

Robert Swindells

Home | Main Index | Thread Index | Old Index