Subject: Re: What does mfspr(SPR_L2CR);?
To: Tim Kelly <>
From: Jochen Kunz <>
List: port-powerpc
Date: 01/05/2005 18:32:04
On Mon, 3 Jan 2005 13:21:51 -0500
Tim Kelly <> wrote:

> Recently someone pointed out that the CPU ID for 604e and 604ev were
> incorrect,
I tested your patches and now my machine doesn't crash. I can't speak
about the power-saving mode stuff, my machine still can't mount / due to
non-existent interrupt routing code. (This is the next thing to do for
port-ofppc. But first I have to fix 43P 7043-140 support for port-prep.)
At least the power-saving patch does no harm as far as my machine goes
through autoconf(9).=20

>> NetBSD/ofppc OpenFirmware Boot, Revision 1.5
>> (jkunz@SirTobie, Fri Aug  8 23:24:09 CEST 2003)
net_open: client addr:
net_open: subnet mask:
net_open: server addr:
net_open: server path: /nfsroot/NetBSD/ofppc
net_open: file name: ofwboot.elf
Using IP address:
root addr=3D192.168.2.14 path=3D/nfsroot/NetBSD/ofppc
2763204+309796 [149888+137879]=3D0x334b54
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 2.99.11 (GENERIC-ofppc) #54: Wed Jan  5 18:14:34 CET 2005
total memory =3D 256 MB
avail memory =3D 240 MB
bootpath /pci@80000000/ethernet@c/netbsd
cbootpath /pci@80000000/ethernet@c
mainbus0 (root): IBM,7043-150
cpu0 at mainbus0 (PowerPC,604e@0): 604ev (Revision 1.0), ID 0 (primary)
cpu0: 375.00 MHz
ofbus0 at mainbus0 (event-sources)
epow-events at ofbus0 not configured
memory-controller@fec00000 at mainbus0 not configured
ofbus1 at mainbus0 (rom@ff000000)
boot-rom@fff00000 at ofbus1 not configured
rtas at mainbus0 not configured
chrp0 at mainbus0 (pci@80000000)
pci0 at chrp0 bus 0
pci0: i/o space, memory space enabled, rd/line, rd/mult, wr/inv ok
pchb0 at pci0 dev 0 function 0: Motorola MPC106 "Grackle" Host Bridge
(rev. 0x40)
pcib0 at pci0 dev 11 function 0: Symphony Labs 83C553 PCI-ISA Bridge
(rev. 0x10)
slide0 at pci0 dev 11 function 1
slide0: Symphony Labs 82C105 IDE controller (rev. 0x05)
slide0: device disabled (at device)
Fixing AMD PCnetPCI Vendor ID.
pcn0 at pci0 dev 12 function 0: AMD PCnet-PCI Ethernet
pcn0: Am79c971 PCnet-FAST rev 5, Ethernet address 00:04:ac:31:1c:7f
pcn0: interrupting at chrp irq 6
nsphy0 at pcn0 phy 1: DP83840 10/100 media interface, rev. 1
nsphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
mpic0 at pci0 dev 13 function 0: IBM MPIC (rev. 0x00)
Symbios Logic 53c875/876 (SCSI mass storage, revision 0x04) at pci0 dev
16 function 0 not configured
ppb0 at pci0 dev 23 function 0: IBM 82351 PCI-PCI Bridge (rev. 0x01)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled, rd/line, wr/inv ok
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq : ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
isapnp0: read port 0x203
boot device: <unknown>
root device:=20