Subject: Boot hangs on PPC (Beige, G3, Desktop)
To: None <>
From: None <>
List: port-powerpc
Date: 07/14/2004 20:51:00
After installing NetBSD on my Power Mac, and setting the recommended variables 
in the Installation Document, the OS hangs during the boot process.  It looks 
like this: 

Open Firmwware 2.0f1
To continue booting the MacOS type: 
To continue booting from the default boot device type: 
For Open Firmware serial I/O type: 
TTYA IO<return> 
0 > boot
OF_open bootpath=ide0/disk@0 
read stage 2 blocks: 01234567. done! 
starting stage 2... 

>> NetBSD/macppc OpenFirmware Boot, Revision 1.7 
>> (, Tue Feb 10 23:44:14 UTC 2004) 
Cannot use bootpath 
Using boot-device instead 
no active package 3872492/ 

it ends with the cursor under the '/', after it stops spinning. 

I would like my Power Mac to boot.  Any ideas? 

Something I didn't see mentioned else where, but that some of you might want 
to know -- when I wrote the NetBSD floppy disk images (boot1.fs and boot2.fs) 
using rawrite2 on a windows PC, I would get read errors when trying to use 
them to install.  When I used dd on a linux machine, they worked fine.  I went 
through 7 disks thinking they all might of had bad sectors before I tried it 
on a linux box. 

- ZT