Subject: Re: le at pci ....
To: Jason R Thorpe <>
From: Anton Gunnarsson <>
List: port-powerpc
Date: 10/24/2001 19:25:52
On Wed, Oct 24, 2001 at 08:14:43AM -0700, Jason R Thorpe wrote:
> On Wed, Oct 24, 2001 at 04:57:42PM +0200, Anton Gunnarsson wrote:
>  > Has anyone used the le (lance) driver for PCI on a powerpc-platform?
>  > 
>  > I'm having troubles getting a Am79c973 working...
>  > 
>  > Any ideas? .. Any experience to share?
> Try using the new "pcn" driver (assuming you are running -current).

Thanks for you quick reply Jason.

I'm in a position where I run the 1.5V kernel and I can't really change
over night, so i tried to modify the driver to work with 1.5V ..

And it works quite well, I get the box up a little bit on the way ...

pcn0 at pci0 dev 12 function 0: AMD PCnet-PCI Ethernet
pcn0: Am79c973 PCnet-FAST III rev 4, Ethernet address 02:00:2b:44:55:67
Registering irq1 type level-triggered level 5 function 0x1912a4
pcn0: interrupting at irq 1
OUI 0x000058 model 0x0036 rev 0 at pcn0 phy 30 not configured
biomask 0 netmask 2 ttymask 2
howto 0 bootdev 0 boot device: <unknown>
root on pcn0            
nfs_boot: trying BOOTP                      
nfs_boot: BOOTP server:                                     
nfs_boot: my_addr=                              
nfs_boot: my_mask=                               
nfs_boot: gateway=                               
root on pear:/usr/netbsd/tarragon2
root time: 0x3bd6ecdb
Setting time to 1003941083
init: copying out path `/sbin/init' 11
pcn0: transmit underrun; new threshold: 128 bytes
pcn0: transmit underrun; new threshold: 248 bytes
Wed Oct 24 18:31:33 CEST 2001
Automatic boot in progress: starting file system checks.
Setting tty flags.
Setting sysctl variables:
Starting network.
Hostname: switch-old
default            done
add net gateway
Configuring network interfaces:.
Building databases...
pcn0: device timeout (txfree 437 txsfree 101)
pcn0: device timeout (txfree 509 txsfree 127)
pcn0: device timeout (txfree 510 txsfree 127)
pcn0: device timeout (txfree 501 txsfree 124)
pcn0: device timeout (txfree 498 txsfree 123)
pcn0: device timeout (txfree 507 txsfree 126)
pcn0: device timeout (txfree 507 txsfree 126)

This is without any PHY's configured in the kernel ... if I configure ukphy,
it will detect it, and then hang at

'nfs_boot: trying BOOTP'

I'we tried booting without PHY's a couple of times, and it always ends up in
'device timeout' ...

Any ideas?