Subject: second internal hard drive on a DS5000/25
To: None <>
From: Brad Thompson <yak@MIT.EDU>
List: port-pmax
Date: 09/06/2000 01:55:38
The short version: NetBSD does not see a second internal hard
		   drive on my maxine.

On my DS 5000/25, there are two internal SCSI connectors, one where the
standard internal hard drive is plugged in and one just in front of the
FDI connector.  The hardware manual has the second one pictured, but
unlabeled.  I decided I wanted another 400M of space, so I took out an
RZ25 from another identical machine with a bad FPU.

I moved the jumper on the left set of pins from the middle set of pins
to the front set of pins to change the drive's SCSI id from 2 to 1 (my
original drive was and is at the factory default of 2).

I removed the floppy drive from the good machine and installed the RZ25
in its place.  The mounting bracket fits fine.  I ran a scsi ribbon to
the second connector and installed a Y-connector on the logic board's
power output with one line going to the first HD and one line to the

The machine in question now had two RZ25 drives, a 25MHz CPU, and 40M
of RAM (8M onboard and 4 8M SIMMs).  When the machine is powered
on and I run cnfg 3, I get:

    KN02-CA V2.0m    (PC: 0x80170ac8, SP: 0xc4c4de28)
    >>cnfg 3
     3: KN02-CA  DEC      V2.0m    TCF0  ( 40 MB)
					 (DV -- d=8)
					 (Sb: devs = 0)
		Name       Rev.       Vendor

					 (FDI: 0)
					 (enet: 08-00-2b-37-57-dd)
					 (SCSI = 7)
		DEV   PID                VID        REV    SCSI DEV
		===== ================== ========== ====== ========
		rz1   RZ25     (C) DEC   DEC        0A00   DIR
		rz2   RZ25     (C) DEC   DEC        0900   DIR

	    dcache( 64 KB), icache( 64 KB)
	    mem( 0):  a0000000:a0ffffff  ( 16 MB)
	    mem( 1):  a1000000:a1ffffff  ( 16 MB)
	    mem( B):  a2000000:a27fffff  (  8 MB)

I had suspected that the second RZ25 might have Ultrix installed on it,
so I ran "boot 3/rz1/vmunix", and it immediately gave me back a ">>"
prompt.  Then, I booted NetBSD 1.4.1 off the first drive.  When I typed
the boot command ("boot 3/rz2/netbsd -a -z 4"), the first drive
spun up.  Here is the dmeg output from that boot:

    Copyright (c) 1996, 1997, 1998, 1999
	The NetBSD Foundation, Inc.  All rights reserved.
    Copyright (c) 1982, 1986, 1989, 1991, 1993
	The Regents of the University of California.  All rights reserved.

    NetBSD 1.4.1 (GENERIC) #38: Mon Aug  9 22:19:29 EST 1999
    Personal DECstation 5000/25 (MAXINE)
    real mem  = 41943040
    avail mem = 34406400
    using 1024 buffers containing 4194304 bytes of memory
    mainbus0 (root)
    cpu0 at mainbus0: cpu0: MIPS R3000 CPU Rev. 3.0 with MIPS R3010 FPC Rev. 4.0
    cpu0: 64kb Instruction, 64kb Data, direct mapped cache
    tc0 at mainbus0: 12.5 MHz clock
    ioasic0 at tc0 slot 3 offset 0x0
    le0 at ioasic0 offset 0xc0000: address 08:00:2b:37:57:dd
    le0: 32 receive buffers, 8 transmit buffers
    scc0 at ioasic0 offset 0x100000: console
    mcclock0 at ioasic0 offset 0x200000: mc146818 or compatible
    isdn at ioasic0 offset 0x240000 not configured
    dtop0 at ioasic0 offset 0x280000
    fdc at ioasic0 offset 0x2c0000 not configured
    asc0 at ioasic0 offset 0x300000: target 7
    xcfb0 at tc0 slot 2 offset 0x0: (1024x768x8) (rcons)
*   Beginning old-style SCSI device autoconfiguration
    rz2 at asc0 drive 2 slave 0 DEC RZ25     (C) DEC rev 0900
    rz2: 406MB, 1476 cyl, 9 head, 62 sec, 512 bytes/sect x 832527 sectors
    boot device: rz2
    root on rz2a dumps on rz2b
    root file system type: ffs

When the boot process got to the line I have marked with an asterisk,
the second drive spun up.  I tried booting a NetBSD 1.5_ALPHA2 kernel
(1.4.1 userland), and got similar results.  Does anyone have any idea
what might be causing the second drive to not show up?