Subject: Re: 3100 Mouse, was Re: New 3100 install
To: None <port-pmax@NetBSD.ORG>
From: Michael L. Hitch <>
List: port-pmax
Date: 02/03/1998 19:38:33
On Jan  3,  6:52pm, Benson L Chow wrote:
> I just got back and have a little time with my 3100 again (yay!) and for
> starters, tried out 1.3beta.  However, I'm also having trouble with the
> mouse not working -- Xcfbpmax would start up fine (after finally reading
> the README.pmax and forgetting about the X11R5 inability to handle
> compressed fonts :-) but the mouse cursor would not move.  I basically
> tried the kernel netbsd.aout under a 1.2D install (booted the 1.3b
> rather than the 1.2D kernel image) as well as a fresh 1.3beta install. 
> In both cases, the mouse cursor would not move in X11.  The "annoying"
> (quote from previous posts...ugh) cursor problem fix seems to be the
> source of the brokenness of the 1.3b kernel.  Anyone else find this to
> be the case?

  I finally got my 3100 connected back together with a monitor and
have verified that I have the same problem.

  I looked at it a bit last weekend, and it appears that I'm not
even getting any data from the mouse at all.  [I've got a printf
in the serial interrupt code, and can see interrupts from the keyboard,
and both serial ports, but not the mouse port.]  It works OK with an
older kernel, so I know it's not a bad mouse.  My guess at this point
is perhaps the serial channel for the mouse is either not getting
set up correctly, or something is disabling the serial channel.

  I've looked at the changes in the serial driver, but haven't been
able to see anything obvious yet.


Michael L. Hitch
Computer Consultant
Information Technology Center
Montana State University	Bozeman, MT	USA