Subject: Console Woes
To: None <port-pmax@NetBSD.ORG>
From: Leo Bicknell <>
List: port-pmax
Date: 08/02/1997 14:59:50
	I have three DECStation 5000/20 or /25's, all bought
from Digital in one large order.  Two are running Ultrix 
(one 4.4, one 4.5) and one is running a week old build of 

	All three machines are currently in a rack running
headless.  I connected the console port to a Cisco 2511
terminal server so I had remote access to all the consoles.
For reference the config on the Cisco router is:

line 7
 login tacacs
 modem Host
 transport input all
 stopbits 1
 flowcontrol hardware

	Now here is the wierdness.  The first machine (Ultrix
4.4 machine) I connected worked great.  I telneted to the 
router after power on, was able to muck around at the boot
prompt, and booted it.  Life was good.

	The second machine (Ultrix 4.5) gave me nothing at
the console port (with the exact same port on the router,
or an identially configured port).  After fear the machine
was dead I connected a monitor and keyboard, opened the machine,
reset the NVRam, and got a console on the graphics device.
I set it to autoboot and changed it back to the serial console.
Still can't see the rom monitor, but when the Ultrix kernel
loads I can see output on the router and things work fine 
from then on.

	With the NetBSD/pmax machine (the interesting part,
no?) I have similar behavior.  I can't see the rom monitor
via the router, but I can see output as soon as the kernel
loads.  More annoying right after the kernel prints out
init: kernel security level changed from 0 to 1
the router closes the connection, and I must relogin to see 
the getty, which then works fine.

	The only thing I can see on the router display is
the control signals differ slightly from machine to machine:

All machines booted and operational:
Modem hardware state: CTS DSR  noDTR RTS

All machines booted with someone connected to the port:
Modem hardware state: CTS DSR  DTR RTS 

First transition after "reboot":
Modem hardware state: CTS noDSR  DTR RTS 

Second transition after "reboot":
Modem hardware state: noCTS noDSR  DTR RTS 

	FWIW: The router seems to key off DSR for
device availability.  Regardless of the options I
try on the router (flow control changes, modem type
changes, turning off all modem options) will not
let me in with no DSR.  The wierd part here is
one gives me DSR at the rom monitor, and two don't.
I haven't tried faking out the router yet.

	Much more annoying is the fact that the last
step in the boot process (after that kernel security
level message) NetBSD seems to "wink" the DSR
line causing the router to disconnect me.  Ultrix
never does this.

	Anyone know how to fix the "wink"?  Can
anyone tell me what the rom monitor should do
with control signals, and what it is observed to do?
I could very well be missing something obvious.