Subject: Re: Valentine's Day kernel, bootblock snapshot
To: Arne Henrik Juul <>
From: Andrew Gallatin <gallatin@isds.Duke.EDU>
List: port-pmax
Date: 02/20/1995 09:25:28
Arne Henrik Juul writes:
 > I've fetched and installed this kernel/bootblocks to our DECstation 3100,
 > and it seems to work quite well - I've done some compilation (of another
 > kernel at least) with it, and while it has some problems there are no
 > new problems that I am aware of.

Can anybody who's had success on a 2100/3100 DECstation using the
miniroot & bootblocks from
Gregorio.Stanford.EDU:/pub/NetBSD/pmax/valentine-snapshot tell me what
version of the prom's your DECstation has?  I'm having zero success
with a 2100 which has KN01 V7.0.  I've tried both cat & dd to get the
bootblocks onto an rz55 & I never get beyond:

Boot: rz(0,2,0)netbsd
Can't boot 'rz(0,2,0)netbsd'

On a somewhat related matter, I've also tried to boot diskless, using
tftp, bootparamd & nfs w/o much success.  Basically, it boots, finds
out where to mount root & swap from, attempts to mount root from a
DECstation running ultrix 4.3a & is denied access to it.  The root and
swap partitions are exported like this:
/netbsd/export/root     -r=0 mips
/netbsd/export/swap     -r=0 mips

(mips is an NIS netgroup that contains the 2100 I'm playing with).

I've made sure the mount request is coming from a privledged port
(1023).  After doing that, I ran a packet sniffer & watched an Ultrix
machine mount something & then watched the NetBSD diskless kernel
mount something.  The main difference that I could see was that the
Ultrix mount says its using auth flavour 1, and sends 88 bytes of
info, including things like a timestamp, the machine name, the uid the
mount request is coming from, the groups that user is in, etc. ... the
NetBSD diskless kernel says its using auth flavor 0 & sends nothing.

Are any other ports booting NetBSD diskless?  If so, are there any
special requirements for the nfs server exporting root?