Subject: Kernel compilation for -current
To: NetBSD/ps2 <>
From: Naopic Tastalian <>
List: port-playstation2
Date: 06/18/2005 18:21:39
Hello everyone,

I moved to -current in order to solve my problem with mfs and /dev partition.
/sbin/init source looked ok, so I built tools and tried to crosscompile the
kernel with, but now it fails to make depend :


cc1: Invalid option '-Wreturn-type'

*** Failed target:  assym.h
*** Failed command: cat /usr/src/sys/arch/mips/mips/ |
/usr/src/tooldir.NetBSD-2.0.2-i386/bin/nbgenassym --
/usr/pkg/cross-ps2/bin/mipsEEel-netbsd-gcc -mcpu=r5900 -mips1 -fno-pic
-D__NetBSD__ -Ulinux -U__linux__ -U__linux -G 48 -mno-abicalls -msoft-float
-ffreestanding -Os -mmemcpy -Werror -Wall -Wno-mail -Wno-format-zero-lenght
-Wpointer-arith -Wmissing-prorotypes -Wstrict-prototypes -Wreturn-type -Wswitch
-Wshadow -Wcast-qual -Wwrite-strings -Wno-sign-compare -Wno-uninitialized
-Dplaystation2 -I. -I/usr/src/sys/arch -I/usr/src/sys -nostdinc -DMIPS3
-I/usr/src/sys/dist/ipf > assym.h.tmp && mv -f assym.h.tmp assym.h
*** Error code 1


The same error occurs with any kernel configuration.