Subject: Re: NEC CD-ROM Drive info & help needed
To: Erik Bertelsen <>
From: Jon Buller <>
List: port-pc532
Date: 07/13/1996 09:39:35
Erik Bertelsen <> wrote:
> On Fri, 12 Jul 1996, Jon Buller wrote:
> ... I have a 2x CD-ROM drive that my ELC reports as NEC CD-ROM DRIVE:2101.0
> ... when I do a probe-scsi.  (Or when I run an inquiry command with
> ... the pc532's ROM raw command.)  It works fine on my Mac/MacOS, but
> ... when I move it to the pc532 and boot netbsd, the kernel spits out
> ... line after line of "ncr0: parity error!" or something real close
> ... while doing the probe.  The ELC's kernel does something similar:
> I have a NEC 210 double speed CD-ROM drive as well. I noticed as part of
> the documentation for my Adaptec 1515 SCSI card for the i386, I must
> disable parity on the SCSI controller to use this drive. 
> This indicates to me that this drive has a known problem with parity, and
> that it probably cannot be solved by changing settings or jumpers on the
> drive itself.

Seems likely that they didn't bother to put parity in their controller 8-(
> With parity disabled on the Adaptec 1515, this drive works with both dos
> and NetBSD/i386. When probed, the drive responds at all LUN's, and I guess
> that a quirk (is that the right buzz word??) to disable LUN's will be
> beneficial, but until now, I have not cared to look enough into the source
> text to formulate and try such a quirk. 

A quirk is the proper thing for disabling extra LUNs as I understand
it.  I will generate such a quirk for the SCSI quirk table provided
someone tells me how (or even if) I can disable parity for one
(preferably, or all if necessary) SCSI target on a PC532 or
SPARCStation ELC.  Monday, I'll try giving 800-NEC-INFO (as found
on their home page) a whirl, not that I'm really expecting anything.
I included port-pc532 and port-sparc since this seems to be heading
that direction (for my problem at least).  I suppose that the ELC
boot ROM can't deal with no parity, since I tried loading Solaris
with it, and it tells me that the image does not appear to be an
executable...  (and I do know about the 512/2048 byte block thing WRT
Solaris, so I tried loading kadb and the kernel, neither worked.)

Any more hints from any experts out there?
Jon Buller <>