Subject: Bootloader trouble
To: None <>
From: Jochen Kunz <>
List: port-ofppc
Date: 03/15/2006 23:52:15

On my mission to get NetBSD/ofppc running on some IBM hardware I came
across three problems:

1. How can I get to the "OK" OFW prompt on an IBM 43P-140 / 7043?

2. When I boot the boot loader on a 43P-150 / 7043-150 I get:
0 > boot net -d=20
BOOTP S =3D 1=20
FILE: ofwboot.elf
Load Addr=3D0x4000 Max Size=3D0xbfc000=20
FINAL Packet Count =3D 114=20
DEFAULT CATCH!, code=3Dfff00300 at   %SRR0: 00c1afe0   %SRR1: 00003030=20
0 > go=20
>> NetBSD/ofppc OpenFirmware Boot, Revision 1.5
>> (build@Zimbo, Wed Mar 15 21:39:04 CET 2006)
net_open: client addr:

I.e. The OFW aborts loading / doesn't execute the loaded image. When I
type "go" to force execution it works and loads the kernel just fine.
But this only works when I start the boot by hand from the "OK" prompt.
It doesn't work when auto-booting.

3. On the 43P-140 / 7043 the boot loader is executed without human
intervention, but it runns really really slow. It looks like it emits
about 1 character per second. It even starts to load the kernel. As
twiddling the the progress bar needs console IO, it loads about one
network packet per second and finaly stops. I also tried to load a
kernel directely via the OFW, without boot loader, but it looked like
the machine didn't recognize the file format.=20

I tried to cheat and prepared a PReP boot image. This is loaded fine but
the kernel seems to hang very early in startup.

It would be nice if someone could help with those boot loader issues.

LOAD: Waiting 60 seconds for Spanning Tree
BOOTP R =3D 1 BOOTP S =3D 1 =20
FILE: ofwboot.elf
Load Addr=3D0x600000 Max Size=3D0xfa00000=20
FINAL Packet Count =3D 114   Final File Size =3D 57952 bytes.
Endian mode : Load Address =3D 600000=20
signature 0x7f454c46 : 7f454c46=20
class           0x01 : 1=20
ei_data         0x01 : 2=20
ei_version      0x01 : 1=20
type          0x0002 : 2=20
machine       0x0014 : 14=20
version   0x00000001 : 1=20
entry     0x02001b40 : 20000=20
phoff     0x00000034 : 34=20
shoff     0x000180f4 : e0a8=20
flags     0x00000000 : 0=20
ehsize    0x00000034 : 34=20
phentsize 0x00000020 : 20=20
phnum     0x00000002 : 1=20
shentsize 0x00000028 : 28=20
shnum     0x0000000a : b=20
shstrndx  0x00000008 : a=20

No ELF note section found in the image !!! Number of program headers : 1

pheader # 1 -------------------------------------
type   =3D PT_LOAD
offset =3D 80=20
vaddr  =3D 20000=20
paddr  =3D 600080=20
filesz =3D d5e0=20
memsz  =3D ff90=20
flags  =3D 7=20
align  =3D 10=20
about to $sync-cache ... ... done with $sync-cache=20
exiting ELF section


>> NetBSD/ofppc OpenFirmware Boot, Revision 1.5
>> (build@Zimbo, Wed Mar 15 21:39:04 CET 2006)
net_open: client addr:
net_open: subnet mask:
net_open: net gateway:
net_open: server addr:
net_open: server path: /nfsroot/NetBSD/ofppc
net_open: file name: ofwboot.elf
Using IP address:
root addr=3D192.168.1.14 path=3D/nfsroot/NetBSD/ofppc