Subject: Re: 2.1 Kernels do not boot when booted with bootloader other
To: NetBSD <>
From: Alex Pelts <>
List: port-mips
Date: 11/20/2005 16:43:47
Some additional information:
CoLo is able to execute generic 2.1, 2.0.1 and 3.0-RC1 kernels. They are 
too big for native bootloader. Unfortunately all of these kernels get 
stuck at "Kernelized RAIDframe activated" line, when booted over the 
network. I guess they would be not good for restore environment.

Also colo is able to boot generic 1.6.2 kernel to the prompt but kernel 
is unable to obtain ip address for some reason. Server does not see dhcp 
requests from that kernel.

Another note : default config, that comes with the 2.1 cobalt, getting 
bus error while processing GENERIC or any other config file derived from 
GENERIC. I had to compile config that comes with kernel source in order 
to compile my custom kernel. This may be the source of my problems.


Alex Pelts wrote:
> Hi,
> I am trying to create restore environment hosted on cygwin and I run in 
> to following problem - 2.1 kernel does not boot when booted with 
> bootloader other than netbsd. I actually tried 2 different ones - qube 
> native bootloader and colo. Both of these are able to boot 1.6.1 kernel 
> that I took of restore cd but nether of them is able to boot 2.1.
> I have two kernels that I compiled and both of them boot from disk. They 
> are booted by netbsd bootloader. When I try to boot them over the 
> network with colo or builtin qube firmware they get stuck after 
> following lines:
> invalid bootinfo (standalone boot?)
> [ Kernel symbol table missing! ]
> These are the last lines I see, and nothing happening anymore. What 
> could be causing this ? Next I will try GENERIC kernel, but I suspect 
> that I will get the same result.
> Anyone is willing to help me? Kernels past 2.1 may have this problem as 
> well.
> Thanks,
> Alex