Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Possible bug in ibmcpc driver

On 04/04/2013 07:18 PM, Michael wrote:

On Thu, 04 Apr 2013 17:30:32 +0200
Phileas Fogg <phileas-fogg%mail.ru@localhost> wrote:

On 04/03/2013 11:00 PM, Phileas Fogg wrote:

i'm trying to boot NetBSD HEAD on my PowerMac G5 in bridge mode
and stumbled upon an odd isuue. The kernel panics in
extent_alloc_region with the message

extent_alloc_region: extent `%s' (0x0 - 0x0)
extent_alloc_region: start 0x%fa500000, end 0x%00100000
extent_alloc_region: region lies outside extent

I tried to debug this issue and found out
that bus tags sc_iot and sc_memt are not zeroed out
after each call ofwoea_map_space in ibmcpc_attach.
Adding bzero before ofwoea_map_space solved the issue but
the kernel paniced now in memio_map at line 601
with the message

"bus_space_map failed: ENOMEM"

Killing the if statement solved the issued then finally.
And PCI enumeration and mapping works on G5 now.


Hmm, the same problem on uninorth.c now :(
It worked perfectly on NetBSD 6.0.1 and on NetBSD head
i can't get my Nvidia card working with genfb.

Odd, my GigE G4 with a geforce 2 mx still works.
I did see something similar with cpc though - the bge's failed to
initialize because of preposterous addresses used in bus_space_map().

have fun

Yeah, bge doesn't work now too.


Home | Main Index | Thread Index | Old Index