Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

iBook G3, nfs-root over gem(4) & NetBSD-6.0 -> problem


anyone here successfully running NetBSD 6 on an iBook with G3
and gem(4) interface?  Those with uni-north pci-bridge/pci-chip/
what ever?

I have the problem that I cannot longer boot NetBSD 6 from
network.  It'll hang after a very short period in some nfs
processes.  Sometimes I get gem(4) related error messages.  I
opened a pr some time ago (kern/46083), but since nobody
reacted, I thought I try to get information on this mailinglist.

Sadly compiling a kernel with GEM_DEBUG and GEM_DEBUG1 options,
doesn't give additional hints.  I do not see additional output
on the console.

Booting from network with 5_STABLE from beginning of year was
possible without problems.  I don't think the network interface
is broken as I tried with some other OS and the interface works
like a charm.

I just retried with NetBSD-5.2 (I do not find any release
announcement, but there were binary sets on the servers).  From
the very same nfs-server the system boots and works like a charm
even under heavy network usage.

Furthermore I was unable to enter ddb with Command+Option+Power.
It just did nothing.  And I'm missing a lot of foo to understand
how to configure hw.cnmagic to get to the ddb prompt.

As I tried only booting from network as I do not want to wrack
the other installed on the harddisk, I'm quite lost and don't
  a) why it is behaving such weird (looking at gem&pci changes I
     cannot make out a patch that should cause this), and
  b) how to debug this.

Any suggestions/tips how to continue from here?

    Matthias Kretschmer

Home | Main Index | Thread Index | Old Index