Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: On-disk kernel hanging after install

Hash: SHA1


On Apr 9, 2011, at 5:21 PM, Julio Merino wrote:


I had a Mac Mini G4 1.2Ghz happily running NetBSD 5.1.  For some
reason I'm not going to bother you with, I have had to reinstall OS X
on the machine and now I am trying to get NetBSD back in, but this
time shooting for a -current snapshot.

I have built NetBSD-current today and the installer works just fine:
"boot cd:,OFWBOOT.XCF;1" gets me into sysinst and everything works
perfectly.  Note that I had to manually set up a pdisk similar to the

#:                type name      length   base      ( size )
1: Apple_partition_map Apple         63 @ 1
2:           Apple_HFS Boot      204800 @ 64        (100.0M)
3: Apple_UNIX_SVR2 Swap 2097152 @ 204864 ( 1.0G) S1 SFS k0 (swap) 4: Apple_UNIX_SVR2 Root 153999472 @ 2302016 ( 73.4G) S0 RUFS k0 /

Then I copied ofwboot.xcf into the Boot partition (with hfsutils, but
also tried from within the OS X installer).  The funny thing is the
machine is unable to boot.  When it loads the on-disk kernel, it
either freezes after "No ADB support present, assuming USB keyboard"
or panics immediately afterwards.  (I'm using
boot-device=hd:,\ofwboot.xcf and boot-file=netbsd , which are the
exact same settings I had before the reinstall.)

I have tried everything I could think of so far.  I "downgraded" the
root partition from ffsv2 to ffsv1 with the same results, tried the
ofwboot.xcf from the cd and from /usr/mdec, and I even tried putting
the installer kernel as /netbsd on the root disk to see if things
moved at all.  But the same problems pops over and over again.  The
weirdest thing is the latter I mention: how come the exact same
installer kernel boots just fine from the cd but panics from the hard

Any other ideas / tips?

You can just make an iso9660 image with only ofwboot.xcf in it, dd it to the first sectors of the disk, then disklabel it ( don't bother with pdisk, ofwboot.xcf knows how to find and read disklabels ). Make sure your partitions don't overwrite the iso. We should probably teach sysinst how to do that since this method should work on both old and new world macs.
A suitable iso is here: 

have fun

Version: GnuPG v1.4.7 (Darwin)


Home | Main Index | Thread Index | Old Index