Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: STRANGE ethernet problem on netbsd-4

This sounds mighty familiar - when I first upgraded to NetBSD 2.x,
before the interrupt machinery got some much needed work.  What
release is this?


>Hi, all,
>Not sure what's up, but I'm seeing a strange problem with a four port ethernet 
>ppb0 at pci0 dev 15 function 0: Digital Equipment DC21152 PCI-PCI Bridge (rev. 
>pci1 at ppb0 bus 1
>pci1: i/o space, memory space enabled
>tlp0 at pci1 dev 4 function 0: DECchip 21140A Ethernet, pass 2.2
>tlp0: interrupting at irq 25
>tlp0: Adaptec ANA-6944A, Ethernet address 00:00:d1:20:17:da
>nsphy0 at tlp0 phy 1: DP83840 10/100 media interface, rev. 1
>nsphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
>After running for a while with a lot of network load, the connection to the 
>machine seemed to have become inconsistent. Pinging it gives:
>64 bytes from icmp_seq=10 ttl=255 time=15027.766 ms
>64 bytes from icmp_seq=11 ttl=255 time=14017.536 ms
>64 bytes from icmp_seq=12 ttl=255 time=13017.288 ms
>64 bytes from icmp_seq=13 ttl=255 time=12017.035 ms
>64 bytes from icmp_seq=14 ttl=255 time=11016.785 ms
>64 bytes from icmp_seq=15 ttl=255 time=10026.541 ms
>64 bytes from icmp_seq=16 ttl=255 time=9026.275 ms
>64 bytes from icmp_seq=17 ttl=255 time=8026.042 ms
>64 bytes from icmp_seq=18 ttl=255 time=7025.789 ms
>64 bytes from icmp_seq=19 ttl=255 time=6025.542 ms
>64 bytes from icmp_seq=20 ttl=255 time=5025.288 ms
>64 bytes from icmp_seq=21 ttl=255 time=4025.039 ms
>64 bytes from icmp_seq=22 ttl=255 time=3024.789 ms
>64 bytes from icmp_seq=23 ttl=255 time=2024.537 ms
>64 bytes from icmp_seq=24 ttl=255 time=1024.286 ms
>64 bytes from icmp_seq=25 ttl=255 time=23.766 ms
>64 bytes from icmp_seq=53 ttl=255 time=8.321 ms
>64 bytes from icmp_seq=26 ttl=255 time=27015.431 ms
>64 bytes from icmp_seq=27 ttl=255 time=26015.182 ms
>64 bytes from icmp_seq=28 ttl=255 time=25014.931 ms
>64 bytes from icmp_seq=29 ttl=255 time=24014.680 ms
>64 bytes from icmp_seq=30 ttl=255 time=23014.429 ms
>Note how it drops one second per ping, then cycles back to a large response? 
>Also note that respinse 53 came before 26, 27, and so on.
>This is on a PowerMac 7300 with a G4 card running a netbsd-4 kernel from 
>yesterday's tree.
>Any ideas?
>John Klos

Home | Main Index | Thread Index | Old Index