Subject: =?us-ascii?Q?My=20PowerBook=203400c=20and=20NetBSD=20experience?=
To: None <>
From: None <>
List: port-macppc
Date: 02/27/2006 21:55:04
My PowerBook 3400c and NetBSD experience 

Please understand. I am very new to NetBSD mailing-list and this is my first email. 

Recently I bought an old world PB3400c. It's a very exotic widget in Czech Republic. I decided to install NetBSD 3.0 on it since this OS supports macppc and PowerPC architecture as it is mentioned on the official website. This decision has been shown as a kind of adventure. I found several problems within installation an configuration. Some of them I was able to solve some of them not (hope yet). 

So here are the steps I had to go through. 

The system can't install via CD burned from downloaded iso image (macppccd.iso) 

PB3400 boots from iso9660 cd (files and directory structure same as macppccd.iso) where boot loader and kernel image, something like {OFWBOOT.XCF and NETBSD.GZ} should be (the best way) in root directory. 
Appropriate boot-device and boot-file has to be set in OpenFirmware: 

setenv boot-device ata1/@0:0,OFWBOOT.XCF 
setenv boot-file NETBSD.GZ 

After installation 

setenv boot-device /bandit/ohare/ata/ata-disk@0:0 
setenv boot-file 

Problem(not solved): 
Console text scrolls very slow. 

Allegedly this solves enabling "L2 cache", the cpu's cache. The kernel option OFB_ENABLE_CACHE should be enabled (uncommented) in order to make the L2 cache available. I have compiled the GENERIC kernel with this option but this doesn't help on PB3400c. On a contrary system freezes with message "cpu: ohare L2 cache enable." while loading. "no active package found" message appears at the bottom of the screen. (probably OpenFirmware message). Some oddity is that even without the option enabled the message: "cpu0: ohare L2 cache enabled" appears at very beginning of loading not adjusted kernel, but without effect. 

Problem(not solved) 
Wsmouse enabling, adding screens via wsconfig, wsconsole customization 

error messages: 
wsconscfg: WSDISPLAYIO_ADDSCREEN: cannot allocate memory 
wsmoused: ioctl(WSDISPLAYIO_GETWSCHAR) failed: operation not supported by device 

In my opinion this can't be solved without solving problem previous. 
The section "wscons options" is very limited in macppc GENERIC kernel (in comparison with i386) configuration file. 
Wsmouse requires WSDISPLAY_CHARFUNCS option to be enabled. Wscons requires other options primarily WSDISPLAY_CUSTOM_OUTPUT and some other in order to be customized. But simply putting these options into the config file doesn't help although compilation process (in some cases) succeeds. 

Installing X would be probably next trouble but now I would like to have the text console optimized and running fast. 

I have found some kind of L2 cache treatment at, but this requires further investigation and study. 

Therefore I am writing this e-mail hoping that somebody (willing to share) already solved some problems abovementioned or has knowhow or idea how to fix it.