Subject: Transfer rate problem
To: NetBSD-macppc <>
From: Sean Trifero <>
List: port-macppc
Date: 09/06/2005 16:48:01
With a fresh 2.0.2 install on a g3 I ran into a small snag.  I can't seem to
upload at any significant speed to the NetBSD machine from any other machine
in my LAN.  I downloaded 238mb in 54 seconds, but I can only uploaded 4mb in
54 seconds.  I though it might be a kernel issue so I upgraded to 3.0_BETA,
still the same problem.  Here are some stats:

[root@yosemite ~]# ifconfig bm0
        address: 00:50:e4:80:b1:25
        media: Ethernet autoselect (100baseTX)
        status: active
        inet netmask 0xffffff00 broadcast
        inet6 fe80::250:e4ff:fe80:b125%bm0 prefixlen 64 scopeid 0x1

[root@yosemite ~]# uname -ap
NetBSD 3.0_BETA NetBSD 3.0_BETA (yosemite) #0: Tue Sep
6 09:55:56 UTC 2005 macppc

[root@yosemite ~]# dmesg | grep bm0
bm0 at obio0 offset 0x11000 irq 42,33: address 00:50:e4:80:b1:25
lxtphy0 at bm0 phy 0: LXT970 10/100 media interface, rev. 1

The system is a G3 B&W Revision 2, 350MHz, 128 PC100 SDRAM

Sean Trifero