Subject: Re: wi broken on macppc
To: Thomas Klausner <>
From: Charles M. Hannum <>
List: port-macppc
Date: 07/31/2004 14:44:15
On Saturday 31 July 2004 14:19, Thomas Klausner wrote:
> Hi!
> > Is anyone else using wi(4) PRISM2/2.5/3 cards on macppc?  It hasn't
> > worked on my PB2400 in a long time.  Yet I don't hear anyone else
> > complaining, so I wonder if there is some mistake on my end.
> > Are successful users out there?
> I'm using it under 2.0_BETA on my Powerbook Lombard.
> > The symptom is that the card attaches and configures normally, but
> > doesn't work.
> >
> > If i set the nwid to "", the lights on the card indicate it's found a
> > network, and my network's text ssid and MAC address bssid show up
> > readably in wiconfig.  but the ssid does not show up in ifconfig.
> > ifconfig says 'ssid ""' and 'status: no network'.
> I don't see that.
> I have the problem that after I configure the nwid with ifconfig,
> I have to manually set the media-type to something other than the
> default. Then I can usually use it without problems.
> > If I start tcpdump and dhclient, I can't see any packets, even the
> > ones dhclient is supposedly sending.  dhclient doesn't get a lease.
> >
> > 'wiconfig wi0 -D' reports "No APs available" even though my AP's name
> > shows up under ssid in 'wiconfig wi0'.
> That has never worked for me. It's supposedly a big-endian bug somewhere.

What's the autoconfig output from your card?  One thing that looks like an 
obvious endian bug is in wi_scan_ap():

        case WI_SYMBOL:
                 * XXX only supported on 3.x ?
                val[0] = BSCAN_BCAST | BSCAN_ONETIME;

That should probably use htole16().

I guess there might be a bug buried in wi_info_intr() or wi_scan_result(), but 
it's not jumping out at me.