Subject: Netbsd/macppc 1.6 root device?
To: None <>
From: Jake Feasel <>
List: port-macppc
Date: 10/18/2002 23:50:56
I am having a quite frustrating error with my PB 3400C.  I have managed t=
get Netbsd installed without too much trouble* using the 1.6 release cd,=20
but after I install, when I boot Netbsd, I always get the same error:

boot msgs, etc....

scsibus0: waiting 2 seconds for devices to settle...
boot device: <unknown>
root device: _

It is at this point that I am prompted to enter something.  The reasonabl=
input, wd0a (the root partition I installed Netbsd on) continues on like=20

root device: wd0a
dump device (default wd0b): wd0b (this is what I made my swap)
file system (default generic): ffs
root on wd0a dumps to wd0b
wdc1:0:0: lost interrupt
        type: ata tc_bcount: 512 tc_skip: 0
wdc1:0:0: piomode timed out
wd0c: device timeout reading fsbn 0 (wd0 bn 0; cn 0 tn 0 sn 0), retrying
trap type 700 at ffc031dc
Press a key to panic.

--- this is clearly game over

After reading every doc I could find, I saw info about System Disk, which=
ran after installing MacOS 8.5.  I assumed that just by running this=20
software and using it to change some settings in my OpenFirmware, it woul=
upgrade the firmware in the process.  This is what I was hoping, because =
read that my version of OF (2.0.1) was buggy and System Disk included=20
patches for it.  I also read that these patches were often necessary to=20
apply before netbsd can boot from disk.  However, after doing all of this=
I get no further than I had before I ran System Disk (exact same error,=20
before and after, no matter what options I throw at it).

This is the OF command I used to (try to) boot netbsd from disk:

boot /bandit/ohare/ata/ata-disk@0:0

This is the command specified as necessary for my model ( 3400C ) on the=20
Model Support Page. =20

I have also set my real-base and load-base to the documented values, afte=
the NetBSD install but before my first attempted disk boot.

So what is causing this error?  My model is listed as supported, so I ass=
someone out there has this thing running.  Do I need to add some option t=
the boot command?  Perhaps a root device path?  Do I need to run System=20
Disk again, this time checking some special thing and verifying that it=20
really does apply all of my patches?  Perhaps I need to build a custom=20
kernel and load it somehow (as referenced here: (shudder).

Thanks so much for your help,
Jake Feasel

*(Note- I booted the install cd like this: =20

boot /bandit/ohare/media-bay/ata/atapi-disk@0:0,\OFWBOOT.XCF;1 NETBSD.MAC=

I had a hell of a time to boot this cd, as the docs didn't help.  I found=
some other guy noting this command in his cry for help. This command didn=
work for him but worked for me.  So I include it here for posterity.)