Subject: Re: post install boot problem : boot-device ?
To: Russell McManus <>
From: Henry B. Hotz <>
List: port-macppc
Date: 06/28/2002 16:03:05
At 8:29 PM -0700 6/27/02, Russell McManus wrote:
>I've carefully read through the install notes, and I've made it
>all the way throught the installation of NetBSD 1.5.2 to my
>Powermac 7300 on an internal scsi disk, using the macppc iso
>cdrom image.
>Everything seemed to work fine, partioned the disks, installed
>sets, created device files, root passwd, etc.

Did you partition the disk with our install program or with an Apple 
utility?  If the former then you should be able to boot with

boot scsi-int/sd@0:0,ofwboot.xcf netbsd

Regardless of the boot-{file,device} settings.  If the latter then 
AFAIK you're SOL.

I have not heard that we have gotten a way to boot OF 1 machines with 
real Apple Partition Maps yet.  I know Bill Studenmund, Bob Nestor, 
and several others have tried.  In fact the method that works (where 
sysinst partitions the disk with a NetBSD disklabel) also puts a fake 
APM on the disk for the boot code.

>Now I can't figure out the right incantation to get things to boot!
>I've got load-base and real-base set properly.
>The two variables that I think are most likely borked are
>boot-file and boot-device.  I have them set as follows:
>printenv boot-file
>boot-file   NETBSD
>(I've also tried "netbsd")
>printenv boo-device
>boot-device scsi-int/sd@0:0  /AAPL,ROM
>I've tried changing 0:0 to 1:0, etc. all the way up to 13:0.
>No joy.

The first number is the SCSI ID, and you should know, or be able to 
find out that.  If nothing else it was printed when the install 
kernel booted (target ID I think).  The second number is the 
partition number on the disk and if this were an Open Firmware 3 
machine I'd say try like 7 through 17 or so.

Since the 7300 is an OF 1 machine you can't do that.  You need to let 
sysinst repartition the disk and wipe out the Apple Partition Map. 
Then you can boot using partition 0 of that disk.  You can't also 
have any Apple partitions on the same disk unfortunately.

>I also can't get the dir command to work.  I must not be addressing
>the scsi disk on the system properly, and ideas?
>I booted onto the install cd with this command:
>boot scsi-int/sd@3:0,OFWBOOT.XCF NETBSD.MACPPC
>and that worked fine.
>so why doesn't
>dir scsi-int/sd@3:0,\

Try sd@3:1 or sd@3:2.  I assume this is the official ISO image CD? 
It's a hybred format with both a MacOS and an IOS 9660 partition, and 
some special magic so it will boot under all (?) versions of open 
firmware.  Boot does not necessarily mean dir, so no guarantees.
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government., or