Subject: Re: Can't boot any of my Macs
To: Dave Burgess , <>
From: Chris Tribo <>
List: port-macppc
Date: 07/25/2001 22:51:08
on 7/25/01 9:13 PM, Dave Burgess at wrote:

> How, without access to MacOS, can I bootstrap this system.  I've seen
> references to suntar, etc.  The problem is that I can't get into OF without
> some kind of bootstrap.

    You don't need a bootstrap to get to OpenFirmware, that's the whole
point of it. Your machine will need to have it's output-device environment
changed probably before you will see anything. You should be able to type
blindly though.

    You should be able to rawwrite the boot.fs image to a disk on a Peecee
if you have one available. Or burn ofwboot.xcf and netbsd.ram.gz to a plain
ole' ISO9660

> Every boot disk I've tried on both PPCs gets kicked out as soon as they are
> accessed.  I've tried the boot.fs.  I've put the bootable CD into the CD ROM
> drive.  I've downloaded a dozen *.bin files.

    You are not in OpenFirmware then. OpenFirmware is a white screen with
black text. The MacOS ROM is the grey screen with the Mac face. If you see a
grey screen, you missed OpenFirmware. If you see a black screen, then you
need to switch your output-device environment as per the Model support page,

> Is there any hope that I can get this thing working?


> Now, if someone has a clue about how to get started on my PowerPCs, or
> (failing that) can help me get my Powerbook 170 going too, I'd appreciate
> it.

    The PowerBook 170 is a 680x0 Mac. There is no support for the video chip
yet, so you'll have to use a serial console. And you will need MacOS to boot
to NetBSD on this machine.