Subject: Re: USB keyboard lockup on G3 boot
To: Brad Chapman <>
From: Bob Nestor <>
List: port-macppc
Date: 06/11/2001 20:26:54

>Hello all;
>I've been working at trying to get NetBSD booting on the following
>Blue and White G3
>Open Firmware 3
>USB keyboard and mouse, which are recognized as:
This system and early iMacs have problems with versions of NetBSD beyond 

>can boot. As I enter the root filesystem info, I get the following
>errors on every keypress:
>ohci_intr: ignored interrupt while polling
This only happens when it's prompting for the boot information.  You can 
ignore it and if you get up far enough to build your own kernel you can 
comment out the warning message without harm.

>I saw mentions of this in the archives, but no explanation or
>suggestion. But, despite all of the errors, I can enter the
>root, swap and filesystem and continue the boot.
>The problem comes after this, as I am unable to use the keyboard after
>this. Under the default install, the boot will then complain about
>/etc/rc.conf not being configured, and will attempt to drop into a
>single user shell. When I get the:
>Enter pathname of shell or RETURN for sh:
>prompt, the keyboard is completely unresponsive. If I go in and
>configure rc.conf using the install shell, the boot will continue
>until prompted for username and password (soooooo incredibly close!),
>but the keyboard will be unresponsive at this point. I can't type
>anything or get the keyboard to respond at all.
Yeah, it's a known problem (at least for those of us with these systems). 
 There was a change to the USB and wscons code right afterr 1.4.2 was 
released that introduced this problem.  I've found one problem in the 
wscons code, but it's not the only one and it doesn't completely solve 
the problem.

>I have tried both 1.5 and 1.5.1_BETA2 with the same problem, and can
>also not seem to solve it with any combination of mechanisms for
>plugging in my mouse and keyboard (I have tried both in the back of
>the machine, the mouse plugged into the keyboard, without a mouse
>plugged in and with them plugged into different ports).
>I'm completely stuck (again) here, and was wondering if anyone could
>offer any suggestions of anything to try to help finish the boot. I'm
>so looking forward to getting this working.
There is a workaround for the B&W G3 since it has an ADB capability.

1) Unplug the USB and plug in an ADB keyboard and mouse
2) Boot NetBSD with the ADB
3) Enter root, swap and filesystem responses on the ADB keyboard
4) When the system gets to the shell prompt (or login if you went 
multi-user), unplug the ADB and plug in the USB keyboard

The USB will be usable at this point and you can use the system.  You'll 
notice that the ADB is dead even before you unplugged it.  Also you 
_MUST_ boot without the USB installed or this won't work.

An alternative is to install and run 1.4.3 which works just fine on the 
early B&W G3 without this "alternative" boot procedure.  With minor 
changes to the config program you will be able to build custom 1.5 or 
-current kernels and test changes if you'd like to try and debug the 
USB/wscons problem.

Hope this helps, and good luck!