Subject: Re: netatalk help please...
To: Jojo <>
From: Bill Studenmund <>
List: port-macppc
Date: 06/01/2001 11:14:35
On Sat, 26 May 2001, Jojo wrote:

> hi there,
> i have a little question about netatalk. i had it running perfectly and
> then i updated pkgsrc via cvs and lintpkgsrc told that netatalk is
> outdated. so i run a make update and everything seems to compile and
> install fine... except for some file already exists errors on making the

Which directory was already there? Depends on the directory (it already
being there being ok).
Try a make clean, make deinstall, make, make install and see what happens.

> directories [but i guess thats normal]. anyway, now i cant seem to start
> atalkd, afpd starts just fine and i can connect with my mac by entering

If atalkd doesnt' come up, nbp won't work.

> the IP in the chooser. but atalkd gives me some error:
> May 26 12:23:51 pplounge atalkd[231]: restart (1.4b2+asun2.1.3)
> May 26 12:23:53 pplounge atalkd[231]: setifaddr: de0: File exists
> May 26 12:23:54 pplounge atalkd[231]: difaddr(0.0): Can't assign
> requested address

What does ifconfig de0 show here?

> May 26 12:23:54 pplounge atalkd: difaddr(0.0): Can't assign requested address
> May 26 12:23:54 pplounge atalkd: difaddr(0.0): Can't assign requested address
> May 26 12:23:55 pplounge afpd[237]: Can't register pplounge:AFPServer@*

This last error is because atalkd isn't up.

> May 26 12:23:55 pplounge afpd[237]: ASIP started on
> (1.4b2+asun2.1.3)
> the odd thing is that i didnt tinker with the atalkd.conf file at all and
> then i also tried the sample files both leaving them empty and some
> different easy configurations for phase and zone... nothing. any old
> files i have to get rid off to reset the sucker? i dont run any zones so
> the easiest way to configure is suitable for me [but i need afp over IP].
> and what also caught my eye is that it comes up with "(1.4b2+asun2.1.3)",
> but i am running NetBSD 1.5 release...?

Your kernel and includes are up to date, aren't they? atalkd is running as
root, isn't it?

That version string is the netatalk package's version, not NetBSD's.

Take care,