Subject: running sysinst from floppy resets real-base. was Re: bootable iso image
To: port-macppc mailing list <>
From: None <>
List: port-macppc
Date: 04/28/2001 13:23:51
Yes that was the problem, The real-base was -1 not F00000 -- but

I first said to myself - "I set that up before I even started trying
to install," knowing I had used bootvars before I obliterated the
MacOS on my disk.

I ran the printenv command, which prints out the defaults and the
current settings in two columns. (at least on my machine.) It was
wrong. I changed it and everything worked. (Well for some reason video
often takes two or three tries to sync) 

Later I booted from the
install floppy to figure out some networking oddities. (The install
program wants to use tlp0 as the networking device, the actual device
is a Farallon PCI card which is de0 after the install. I don't have it
configured yet and because of the trouble I had doing an ftp sysintall
I wonder if there is a problem here). When I rebooted, after just
running the network install utility program on the floppy, it had
reset the real-base to -1. I was able to repeat this; if you count
just running the program without doing anything with it, i.e. I didn't
touch the actual installation on my hard disk AFAIK.

Realizing that the base had been reset, I tried to boot off of the CDs
again with it set correctly - still no luck there.

Well its almost booting - I just have a file descriptor shortage,
which keeps it from succeeding to boot all the way into multiuser mode
and mounting the partitions. I can mount them by hand, but so far I'm
getting nowhere with networking. If I try to run the /etc/rc.d/network
I get the same "Out of file descriptors" message.

On Fri, Apr 27, 2001 at 11:13:36PM -0700, Michael Wolfson wrote:
> At 10:16 PM -0400 4/27/01, wrote:
> :)0 > boot ata/ata-disk@0:0
> :)>> NetBSD/macppc OpenFirmware Boot, Revision 1.2
> :)>> (matt@duel.local, Thu Nov 16 17:26:57 PST 2000)
> :)2001124+237436 [100+105392|
>   -- MW

Josh Kuperman