Subject: Beige G3 OFW ROM Update
To: None <>
From: Chris Tribo <>
List: port-macppc
Date: 10/02/2000 09:14:53

	Last week I bought a $40 "Rev. B" OFW ROM chip upgrade for my
Beige G3/DT/233 from OWC [Other World Computing] (OF 2.0f1 orginally, the
Rev. 1 G3 logic board).

   Here's the run down on pertinent info:

Still OFW 2.0f1

Automagically identifies and uses add-in video cards as "screen"
	so you don't have to modify your output device value

Floppy booting still works

Fixes Master/Slave ATA/ATAPI: in MacOS at least, I was able to
	boot NetBSD once, and haven't been able to do it again yet.
	I've gotten: can't open, can't load from this device, CLAIM
	FAILED, etc. I'm almost positive I used
	boot /pci/mac-io/ide@21000/disk@0,0:0 and it worked (once)
	Then I swapped out the 500MB WD drive I was working with above
	and put in an NEC 2.1GB drive, when I tried to initialize it in
	MacOS, it froze the computer. I'm hoping this is something to
	the effect of these drives not having Apple ROM's. NetBSD doesn't
	seem to have any problems (though it didn't before either) Also,
	Drive Setup from OS 9.0.4 will not init the two HD's I've tried.
	It writes the partitions, but then says initialization failed. :\

Fixes netbooting: no more TFTP timeouts, significantly faster. If
	someone could post or send me a version of ofwboot.xcf compiled 
	to load at 600000 I could test tftp bootp and go diskless. (It
	actually goes to the load address in ofwboot.xcf now me thinks)
	I know I can specify boot enet:IP.IP.IP.IP,bootfile if I want,
	do I need to specify anything else to ofwboot.xcf in bootp or in
	OFW? Every time it loads it just freezes the computer. I'm 
	guessing "netbsd" needs to be in /tftpboot on the host machine,
	but I don't think it's even getting that far.

Caveats: I don't have a CD to try booting from, so I don't know if you can
boot from Slave drives and/or CD-ROM for sure. I'm told HD performance has
taken a slight hit. You probably need to reset your PRAM 4 times or so,
and also use the reset button on the motherboard behind PCI slot
C. SystemDisk actually seems to break this version of OFW. Hopefully I'll
figure out why I haven't been able to boot from IDE later, and try booting
from SCSI.